Change permissions to allow everyone access to inherited NAS

We have inherited a NAS that has an IP address but I am unclear how to connect and a few of the folks in the office need to copy folders that they do not have access to.  They are all on Workgroup computers which is unusual and can access the NAS through them.

I am on my laptop but a different workgroup.  I have the IP address for the NAS and some usernames and passwords.

Assistance is greatly appreciated.
frugalmuleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smckeown777Commented:
What is the make/model of the NAS? Most NAS have a web interface you can access - have you tried that with a browser?

http://ip-of-nas

Should bring up the login page - the usernames you have try those to see if you can get into the config settings

As for permissions most NAS run with Guest mode and thus allow everyone access out of the box...is this not how things are setup?
0
frugalmuleAuthor Commented:
OK,

Very interesting.  We finally got into the NAS from a web browser both at ip/admin and at ip/shares.  The admin gives more options but I don't see a way to fix the problem there.

I notice that I don't run into any permission issues when accessing folders on the NAS via my laptop despite the different workgroup than what everyone else is on.

When accessing the files from another computer on the workgroup, I don't have permissions to some of the folders.

I would like to restrict permissions somewhat but at least allow one of them to access all the files.
0
smckeown777Commented:
Well obviously this is a Netgear Readynas based on your comment(ip/admin vs ip/shares)

You need to create users on this device to set permissions properly
Default settings on it are open access for all users - read and write

To set specific permissions you need to go into Security-Users and Groups
If you have a laptop user called John(username John on the laptop) you create the same username on the nas and same password...

Then edit the CIFS permissions in the Share Listing section for the share in question...
0
frugalmuleAuthor Commented:
It appears to be a windows permissions issue.  There was a group called nobody which I removed and it now lets me 'attempt' to include Everyone full access for all the files on the NAS.  However, it won't let me change them all and gives me access denied.  Can I force the change?
0
smckeown777Commented:
This NAS defaults to Read/Write for Everyone...

Can you show us a screenshot of the Permissions section for review? Basically once you've set Read/Write as default all folders should be accessible for adding files to...

Have you created the users on the NAS to match the windows users? That's the only way to make this work bar you just give everybody complete open access to it

Show us some of the screenshots so we can see what is missing here
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.