Outlook 2010 password prompts and certificate errors

Up until a few weeks ago, people were able to undock their laptops in the office with Outlook 2010 running, it would show disconnected for a few seconds and then automatically reconnect. Even if their laptop went to sleep Outlook would automatically reconnect once it woke up. Now after it disconnects it prompts for credentials, as well as displays an error stating "There is a problem with the proxy's security certificate. The name on the security certificate is invalid or does not match the target site webmail.company.com. Outlook is unable to connect to the proxy server".

So far I've tried enabling kernel mode authentication under the Windows Authentication setting for Autodiscover, EWS, OAB, and RPC virtual directories in IIS. I've also checked and the authentcation method used is NTLM. I do have "on slow networks use HTTP" checked, but "on fast networks use HTTP" is not checked. I tried checking that and it wouldn't let me log in at all.

I'm not sure what or if anything has changed right before this started as I had left the company a few months ago and came back right after this started.

Exchange is setup on 2 CAS/HUB servers, 2 Mailbox servers, and 1 EdgeTransport server. The version I'm running is Exchange 2010 SP2 Rollup 6 running on Server 2008 R2. Clients are Windows 7 Enterprise 64-bit.

I've read a lot of articles on this issue but none of what I've read and tried has seemed to work at all. Any ideas? It would be greatly appreciated.
Rick GoodmanNetwork AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

edster9999Commented:
When you are docked and you move to undocked, are you on the same network.
DO you have the same IP, subnet and routes ?
Do you go out through the same proxy or is it different ?
0
Simon Butler (Sembee)ConsultantCommented:
You need to look at the certificate that is being returned to see if it is the same certificate or not. It could be that the clients are connecting somewhere else.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Magnus BIT-supportCommented:
Hi
Try turning off application control on your antivirus software and see if that makes it better. That can interfere and generate this problem.

/MadJax
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Milan_rCommented:
Check exchange certificate is valid for "webmail.company.com" if it 's valid then register internal URL as shown in MS article "http://support.microsoft.com/kb/940726"
0
Rick GoodmanNetwork AdministratorAuthor Commented:
Thanks all, sorry for the delay, I was out for a while. I'm going to look into these options, hopefully this week yet. I do appreciate the advice.
0
Rick GoodmanNetwork AdministratorAuthor Commented:
I think it could be a certificate issue, although, for whatever reason, I don't seem to be seeing the issue much anymore. But a short time before this problem started happening I did renew my 3rd party SSL certificate (for IMAP, POP, IIS, SMTP), which before had my CAS/HUB servers listed as a SAN (i.e. server1.company.local) on the certificate, now they no longer let you add that as a SAN. My self signed certificates on my two CAS/HUB servers (for SMTP) only have itself (server1.company.local) listed on them. So I'm not sure if that would cause an issue or not. I thought these certificates were just for trust bewteen the Exchange servers. Any ideas?
0
Simon Butler (Sembee)ConsultantCommented:
Look at the output of

get-exchangecertificate

You may well find the self signed certificates are just bound to SMTP, which is fine.

Simon.
0
Rick GoodmanNetwork AdministratorAuthor Commented:
I wish I could say what was causing it, but I don't know that I'll ever know as it seems to have gone away, very weird. By the way, I did run the get-exchangecertificate and the self-signed certificate is just bound to SMTP, the 3rd party certificate is what's bound to the other services. Thanks again all for the input, wish I could tell you what the cause and solution was, just don't know if I'll ever know.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.