multicast on cisco 3750 and cisco rv180 - only receiving unicast

I've been struggling with multicast for some bit now.  I receive video through unicast.

The following is true:

A 3750 is configured as such:
interface GigabitEthernet1/0/11
 description Uplink to CiscoRV180
 no switchport
 ip flow ingress
 ip flow egress
 ip address
 ip pim sparse-mode
 ip igmp query-interval 125
 flowcontrol receive desired
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
 spanning-tree bpduguard disable

ip pim rp-address
no ip pim dm-fallback
ip mroute
ip route GigabitEthernet1/0/11

router eigrp 64512
 redistribute connected
 redistribute static
 passive-interface default
 no passive-interface TenGigabitEthernet1/1/1
 eigrp router-id

connected to WAN port on the RV180 switch:

WAN Information-
IP Address:
Subnet Mask:

Routing Mode: Gateway (NAT)

Access Rules:
Default Outbound: Allow

One-to-One NAT
Private Range:
Public Range: 196
Service: ANY

IGMP Proxy: Enable
Upstream: WAN
Allowed Networks: - 154 Length - 32

I can see the video in unicast but can't see it in multicast.  Do I have the routes right?  

multicast debug is on. I see no traffic concerning 172.27.91.x.
Who is Participating?
zfishConnect With a Mentor Author Commented:
None of the solutions worked.  Had to take Router out of the mix for broadcast to work.
Craig BeckCommented:
Have you configured PIM on the VLAN where the multicast source resides?
Als oyou have to configure multicast globally with "ip multicast-routing "
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

zfishAuthor Commented:
Yes to both.  Multicast is working for other switches and subnets on the same switch but not this particular one.  It's going to an RV180 connected to the WAN port from the switch that is receiving multicast from other devices on the same switch.  The RV180 has multicast within its LAN but outside the WAN it isn't passing through.  One to one nat is setup for that RV180.
Craig BeckCommented:
Can you turn NAT off on the RV180?
zfishAuthor Commented:
I don't think so because the network on the WAN side of the network has a 172.27.x.x address.  The network on the LAN side has network address in 192.168.2.x.  If I turn off One to One NAT both networks wouldn't be able to even see each other; let alone pass multicast.
zfishAuthor Commented:
None of the solutions worked.  Had to take Router out of the mix for broadcast to work.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.