GPO is disabling proxy settings when it shouldn't be

Hi all,

As the title suggests, we have a computer joined to our domain which needs to have custom proxy settings enabled for Internet Explorer. Each time gpupdate runs it clears the use proxy checkbox, however to the best of my knowledge there are no GPO's linked that should even touch proxy settings.

Here are all the details I have so far;

2 computers on a remote site are joined to our company domain and in the same OU.
Both computers are logged in with the same user, both with the same custom proxy settings set.
The first computer (PC1) keeps its proxy settings when gpupdate /force is run, the other (PC2) does not. The proxy address is saved, however the use proxy settings checkbox is cleared.
I have rejoined the problem computer (PC2) to the domain, with a new computer name and moved it to the correct OU (same OU as PC1).
Both PCs are Windows XP SP3 with IE8.
IE 8 has been reinstalled from add/remove programs.
IE settings have been reset from advanced tab.
There are no toolbars/extensions/add-ons etc outside of the default MS ones + Adobe + Java which are disabled.

It is definitely group policy that is applying the change but it has me stumped as to what policy is doing it, and why it is doing it, considering the PCs are in the same OU along with the same user account being used on both. You would expect them to behave the same.

Any help provided is greatly appreciated.
LVL 1
MHJITSUPPORTAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smckeown777Commented:
Give us the output of

gpresult /v > gp.txt

Run that from a command prompt and it will create a file called gp.txt in the folder you run from...

These 2 machines - patched to the same level?
0
smckeown777Commented:
Want that for the 2 machines sorry...same command on both
0
CoralonCommented:
Do a GPResult and Group Policy Modeling against the machines.  There are multiple ways the proxy settings can be set - Group Policy Preference, direct registry key, IE maintenance, etc.

Coralon
0
MHJITSUPPORTAuthor Commented:
Thanks for the replies smckeown777 and Coralon. Using gpresult as you both suggested I was able to find the culprit.

We have a home page policy that configures User Configuration > Preferences > Control Panel Settings > Internet Settings > Internet Explorer 8. Although we had not specifically changed the properties under Connections > LAN Settings, by default the Proxy server "Use a proxy server for your LAN" option is underlined green meaning the policy is enabled and the option is unchecked.

Using F7 and F8 (defined in this Technet article) I have disabled all options on all tabs other than the home page setting that we require.

I knew it would be something silly.

I still do not know why this change was occurring on one computer and not the other. The gpresult output from both PC's showed that the same policies were being applied.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MHJITSUPPORTAuthor Commented:
Was guided in the right direction by experts. Clearly defined solution in self post.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.