Etherchannel for 2 Cisco 2960's

I'm a software guy and new to setting up switches. I was told I can setup an Etherchannel on my 2 new Cisco C2960X-48TS-L switches. I was told I can connect both switches together with just 1 cable, or setup Etherchannel and use 2 cables for double the bandwith. I'm not sure how to proceed. I've done quite a bit of research. Here is what I have come up with but not tried out yet. I'm not sure if what I have is even correct, and if I should use trunk or access or what mode to use. Just want to connect these 2 switches using 2 cables.

Switch1> enable
Switch1# configure terminal
Switch1(config)# interface range GigabitEthernet1/0/47-48
Switch1(config-if-range)# switchport mode trunk
Switch1(config-if-range)# channel-group 1 mode desirable
Switch1(config-if-range)# end

Switch2> enable
Switch2# configure terminal
Switch2(config)# interface range GigabitEthernet1/0/47-48
Switch2(config-if-range)# switchport mode trunk
Switch2(config-if-range)# channel-group 1 mode desirable
Switch2(config-if-range)# end
cb_itAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rauenpcCommented:
The choice between trunk and access mode is simply whether or not you intend to pass multiple vlans between the switches. In most situations links between switches are configured as trunks, even if there is only a single vlan because it allows for a non-disruptive ability to add vlans in the future.

I would also recommend going with the port channel for both bandwidth and failover abilities assuming you have the ports to spare. Also, there is nothing wrong with using the "desirable" mode for the port channel, however, I would recommend going with "active" mode instead on both ends. The difference is that desirable uses a Cisco proprietary protocol and active uses a standards based protocol. There is no advantage in either protocol when dealing with Cisco switches, but without any advantage I would suggest going with the standards based protocol.

One thing to bear in mind when it comes to etherchannel bandwidth. A single session, such as a file transfer, will only use a single physical port in the etherchannel. This means that the bandwidth for a single session will never exceed the bandwidth of a single link within the etherchannel. You can have multiple sessions occurring simultaneously that utilize the full bandwidth of all links, but the individual session can only use one link.
0
cb_itAuthor Commented:
Thanks for the very quick reply. Sorry for the beginner questions but what does 'going with the port channel' mean exactly? Would I have to add anything to my config? And does my config look good? Thanks again.

Switch1> enable
Switch1# configure terminal
Switch1(config)# interface range GigabitEthernet1/0/47-48
Switch1(config-if-range)# switchport mode trunk
Switch1(config-if-range)# channel-group 1 mode active
Switch1(config-if-range)# end
0
rauenpcCommented:
Port-channel and etherchannel are interchangeable terms in the Cisco world. The configuration looks good. One thing you will have to check after running those commands is the actual port-channel configuration. Depending on the code version you will either need to configure the port-channel for trunk mode, or you might not need to do anything. So after running the commands, look at the running configuration and you'll see an interface port-channel 1 which should be configured as a trunk. If not,

config t
interface port-channel 1
switchport
switchport mode trunk
no shut


and you should be all set.
Other good commands are "show interface port-channel 1", and "show etherchannel summary". These will verify that the port-channel is up and both interfaces are members.

One more thing. Depending on the switch model and code version, you might also need to run the command "switchport trunk encapsulation dot1q" to each trunk interface including the port-channel.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cb_itAuthor Commented:
OK, I will test these out in a bit and get back to you. Thanks again for the quick replies.
0
cb_itAuthor Commented:
Hello, this worked perfect. All of the commands are in and it seems to be fine. The port channel was already configured for trunk mode after these commands, nothing else to do. Here is part of my config now.

interface Port-channel1
 switchport mode trunk
...
interface GigabitEthernet1/0/47
 switchport mode trunk
 channel-group 1 mode active
!
interface GigabitEthernet1/0/48
 switchport mode trunk
 channel-group 1 mode active

When I run show interface port-channel 1 I can see BW 2000000 Kbit/sec

Thank you again for the quick replies and great help, and not just providing a link.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.