• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1541
  • Last Modified:

DCOM security persmissions greyed out

Hi am getting this error and have tried everything:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
 and APPID

I have gone to regedit and set administrators as owners and given full control but the security section of the DCOM settings is still greyed out.

Server is 2012 with SharePoint 2013 installed.
1 Solution
Administrators arent neccesarily the issue here:

I have run into this with sharepoint 07 and 2010 and it, for me, involves going into the DCOM Config and adjusting the settings for the WSS_WPG and WSS_Admin_WPG groups and give them local activation and local launch, as explained in the article.

Since it is service accounts that run this service, giving admins permissions over this will have no effect
Justin SmithSr. System EngineerCommented:
you need to grant access to the registry key (HKCR/AppID/{6173xxx}).  May have to make admins the owner, then give admins full access
joey5630Author Commented:
OK have checked the following:

{000C101C-0000-0000-C000-000000000046} has now got the local server administrators group as owner and administrators have full control in permissions which was set in regedit

I have gone to DCOM Config and selected properties on the same DCOM unit and it is still greyed out. Is this something specific to Server 2012?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now