DCOM security persmissions greyed out

Hi am getting this error and have tried everything:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{000C101C-0000-0000-C000-000000000046}
 and APPID
{000C101C-0000-0000-C000-000000000046}

I have gone to regedit and set administrators as owners and given full control but the security section of the DCOM settings is still greyed out.

Server is 2012 with SharePoint 2013 installed.
joey5630Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vaderjCommented:
Administrators arent neccesarily the issue here:
http://www.ericjochens.com/2013/06/sharepoint-server-eventid-10016-dcom.html

I have run into this with sharepoint 07 and 2010 and it, for me, involves going into the DCOM Config and adjusting the settings for the WSS_WPG and WSS_Admin_WPG groups and give them local activation and local launch, as explained in the article.

Since it is service accounts that run this service, giving admins permissions over this will have no effect
0
Justin SmithSr. System EngineerCommented:
you need to grant access to the registry key (HKCR/AppID/{6173xxx}).  May have to make admins the owner, then give admins full access
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joey5630Author Commented:
OK have checked the following:

{000C101C-0000-0000-C000-000000000046} has now got the local server administrators group as owner and administrators have full control in permissions which was set in regedit

I have gone to DCOM Config and selected properties on the same DCOM unit and it is still greyed out. Is this something specific to Server 2012?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.