Help! Aironet 1040 configuration

Hi All,  I recently set up a Cisco Aironet 1040 AP.  Users that are fairly close to the AP's are having issues spooling print jobs every time.  What is strange is that they don't seem to be having issues dropping off the network though. They are using the native windows zero config client to connect.  I'm a Aironet/Cisco newbie, so bear with me.  Here is the config.  Is there anything obvious that I'm missing?  The users having issues are on VLAN2 (not the Guest network).  If the config looks Ok, what's that best way to troubleshoot.

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
logging rate-limit console 9
enable secret 5 $1$w8hH$F5jNtY0tRf1mqinnFTeDN/
!
no aaa new-model
!
!
dot11 syslog
dot11 vlan-name GuestVlan vlan 3
!
dot11 ssid PMM
   vlan 1
   authentication open 
   authentication key-management wpa version 2
   guest-mode
   mbssid guest-mode
   wpa-psk ascii 7 mypresharedkey
!
dot11 ssid PMM-Guest
   vlan 3
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 7 mypresharedkey2
!
!
!
username Cisco password 7 mypassword
!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm 
 !
 encryption vlan 1 mode ciphers aes-ccm 
 !
 encryption vlan 3 mode ciphers aes-ccm 
 !
 ssid PMM
 !
 ssid PMM-Guest
 !
 antenna gain 0
 mbssid
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.3
 encapsulation dot1Q 3
 no ip route-cache
 bridge-group 3
 bridge-group 3 subscriber-loop-control
 bridge-group 3 block-unknown-source
 no bridge-group 3 source-learning
 no bridge-group 3 unicast-flooding
 bridge-group 3 spanning-disabled
!
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 no keepalive
!
interface GigabitEthernet0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.3
 encapsulation dot1Q 3
 no ip route-cache
 bridge-group 3
 no bridge-group 3 source-learning
 bridge-group 3 spanning-disabled
!
interface BVI1
 ip address 10.10.10.191 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.10.10.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
end

Open in new window

polaris101Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Craig BeckCommented:
Config is spot-on!

All I'd ask is that you check the switch.  You mentioned VLAN 2 in the OP, but the PMM network is on VLAN 1.  Therefore, just check you have the native VLAN configured correctly on the switch.

Post the config if you're unsure.
0
polaris101Author Commented:
Thanks CraigBeck,  I actually meant the users having issues are on VLAN1, the Internal LAN.  My mistake. VLAN3 is the GuestVlan. The AP is actually connected directly to the ASA.  Users are occasionally losing connection to internal resources such as internal DNS and network shares.  Any thoughts on the best way to troubleshoot this issue ?
0
Craig BeckCommented:
Check the ASA logs when the issue occurs. What do you usually do to get things working again?
0
polaris101Author Commented:
Nothing significant in the logs.  Issue seems to have resolved after connecting AP's to a PoE switch instead of directly to ASA.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
polaris101Author Commented:
Seems to be resolved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.