Unable to add Passthrough Disk

Hello

I have a virtualised network with the following hardware:

2x HP DL380 Servers
1x P2000 SAN
2x HP Procurve 2901-ag switches

We are also using Hyper-v.

All is working well with one exception - we have a file server and are trying to add a 4.6TB drive. Obviously we are limited with a VHD which is why we are trying to use pass through.

I have been battling with the Microsoft article "Hyper-v: How to add a pass-through disc on a failover cluster and also KB article 2501763.

Basically these documents seem to be quite vague and are lacking detail.

To cut a long story short I have a LUN which I am trying to use for the File server and have managed to get the drive added to the VM but only as read only. The article 2502763 doesn't resolve this issue.

Any thoughts would be much appreciated.

Chris
LVL 1
cmlbaeteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
If the drive is read only, that has nothing to do with clustering or virtualization, but rather the default behavior when adding drives. Use diskpart.exe in guest to clear the read only attribute.

If you use Windows 2012 or higher for the hypervisor you can use vhdx for the drive which can be much larger than 2 tb. Another option is to use the iSCSI initiator inside the VM to connect directly to your SAN and skip the whole passthrough disk thing.
0
cmlbaeteAuthor Commented:
Thanks for your reply post.

Sadly we are using Server 2008 and not 2012 so that is not possible. I have tried using the dispart utility but although that said it had worked its still read only, even after a reboot.

I may have a look at the ISCSI setup but that is a slightly grey area to me.
0
cmlbaeteAuthor Commented:
This has now been sorted - thanks for all your posts on here.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cmlbaeteAuthor Commented:
This is not the solution - I don't have this as I got this fixed with a comsultancy.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.