Exchange 2007 Activesync smartphones can only get 30 days email

No one has ever complained before, but smartphones users (if they choose to) cannot sync all of their email (I know the merits of this can be debated) However I have an Sr. Executive who insists on receiveing all of her email on her Windows Nokia phone.  I checked my own phone and I was set at 3 days, changed to 30 days (the most available to me) and synced without issue. However, looking online I see that some Exchange 2007 activesync users can see the "all" selection. I checked my Exchange server and on the Organizational level there is only the default activesync policy and it is set at "ALL" for both include past calendar items and past email items. I see no other policies on the server level that might override this.

Is there something else I need to do or check on the exchange server? Is this a limitation based on phone? Sr. Exec is a new hire who works remotely, I have never met her nor worked with a windows phone though I suspect that is probably not the issue as I am seeing the same thing on my Verizon Android phone.

If it helps, we are running exchange server 2007 std on Windows server 2003 std.

Any insight or suggestions? Thanks.
and_the_beat_goes_onAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas GrassiSystems AdministratorCommented:
My Iphone 5 with IOS7 has a setting for No Limit.

It is the limitation of the phones software.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nathan PSystems ArchitectCommented:
My iPhone 5 with iOS 7 has not got a 'No Limit' setting for my Corporate ActiveSync. (Exchange 2010, I'm the administrator!)

It's based on Policy in Exchange 2010.. available under Exchange Management Console - Organization Configuration - Client Access - Exchange ActiveSync Mailbox Policies.


ActiveSync Policy Settings - Exchange 2010
0
Thomas GrassiSystems AdministratorCommented:
I am running exchange server 2007 I will check the setting when I get on site.

But my iphone 5 does have the setting.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Nathan PSystems ArchitectCommented:
http://technet.microsoft.com/en-us/library/bb691441%28v=EXCHG.80%29.aspx

Organization Configuration > Client Access > Exchange ActiveSync Mailbox Policy Synchronization Settings Page
This topic has not yet been rated - Rate this topic

 

Applies to: Exchange Server 2007 SP3, Exchange Server 2007 SP2, Exchange Server 2007 SP1, Exchange Server 2007

Topic Last Modified: 2007-07-30

You can create a Microsoft Exchange ActiveSync mailbox policy to configure a variety of security options for users. In addition to password requirements and settings, you can use the Sync Settings page to specify a variety of synchronization-specific settings.

Include past calendar items

    Use this drop-down box to select the date range of calendar items to synchronize to the device. The available options include the following: All, Two Weeks, One Month, Three Months, and Six Months. If you have to specify other options, use the Exchange Management Shell to configure this setting.

Include past e-mail items

    Use this drop-down box to select the date range of e-mail items to synchronize to the device. The available options include the following: All, One Day, Three Days, One Week, Two Weeks, and One Month. If you have to specify other options, use the Exchange Management Shell to configure this setting.
0
and_the_beat_goes_onAuthor Commented:
That's the curious thing, my organization level default activesync policy is already set at "all" for both past calendar items and past email items. There are no other activesync policies there and this one has been in place and not changed since 2008.
0
Thomas GrassiSystems AdministratorCommented:
See attached that is my iphone 5 settings on my exchange 2007 server

again I will check my policies tonight when I am on sight
IMG-0136.PNG
0
Nathan PSystems ArchitectCommented:
I should be clearer.

If the Exchange Server is not limiting the number of email days..
Then perhaps it is the Nokia Windows phone enforcing the limitation.

My suggestion:  Check your other users phones.. (hopefully iPhones or Androids) and see if they can set No Limit on their mail collection.

If so = Nokia Windows Phone limitation
If not = Something else is up.
0
Thomas GrassiSystems AdministratorCommented:
AS I said it is the phone IOS software that is doing that. As I put in my first post.

Does anyone on your network have an Iphone? I do not remember if IOS6 had this never had to check always had just 3 days set not away from my outlook that often.

But and Iphone 5 with IOS7  does have the option you require.
0
and_the_beat_goes_onAuthor Commented:
ok, I just went around and asked a few users to give me their phones, it appears, just as trgrassijr55 said to begin with, it is limited by the phone. I had an iphone user who saw "all",
a Motorola Droid X2 user who only saw up to 30 days, a Motorola RAZR user who saw "all" and of course this Nokia user who only sees up to 30 days. I am now convinced (and glad that my server was configured correctly) :-)

Thank you everyone, I am awarding the points to trgrassijr55 because he posted the first answer and it was correct.
0
Thomas GrassiSystems AdministratorCommented:
Hi

I just check my Exchange Server 2007 Client Access
Exchange ActiveSync Mailbox Policies
Default Properties

see attachment

Mine has a six month setting

maybe you need to use the default policy

if you need all the settings of the policy let me know
activesync-settings.bmp
0
and_the_beat_goes_onAuthor Commented:
Thanks TR, but mine is already set to "all" and I am using the default policy setting, I think as you suggested earlier, it is dependant on phone make/model. I was able to confirm that some phones could see the "all" settings while others could not. You might not have seen it yet, but you were awarded the points. Thanks again for all your help and your promised follow-up.
0
and_the_beat_goes_onAuthor Commented:
Thought I closed this previously, apparently did not.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.