Two routers on one network

Hello.  I don't know much about networking and I am trying to figure out the best way to do this:  I have a Comcast wireless router that also has some hard-wired connections.  The wired connections always work fine, but he wireless portion loses the internet on a regular basis.  My solution to this is to add my own wireless router connected to the switch portion of the Comcast router.  The Comcast router is on the 192.168.1.x subnet, and I have configured the additional router to be 192.168.2.x.  Everything works fine and I have a solid wireless signal now, but my wired workstation on the 192.168.1.x subnet can't communicate with anything on the 192.168.2.x subnet.  I suspect this is just a matter of changing the netmask, but I'm really not sure.  How can I make this work like a single network?  Thanks in advance!
dkreinesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris MillardCommented:
If your netmask is /24 (255.255.255.0) then you are correct - you'll need to change the netmask to at least /23 (255.255.254.0) to have 192.168.1.x and 192.168.2.x communicating with each other.

There is an excellent online IP subnet calculator at http://www.subnet-calculator.com/ that you can use to work these out
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Don JohnstonInstructorCommented:
If you need the wired network to communicate with the wireless network, you'll have to create a route on the Comcast router for the 192.168.2.0 network with your router as the next-hop address.

But I suspect that your original wireless problem is due to the Comcast device using an already in use channel. You should be able to login to the Comcast router and select a different wireless channel.
0
profgeekCommented:
You can disable the wireless on your Comcast modem/router and then put your wireless router into wireless access point mode.  Doing that, it will use the same network as the main router and use the main router for DHCP (issuing IP addresses to connecting devices).  If you want everything in the same network, that's the way to go.

Your method would work well if you wanted to isolate the wireless clients from the wired network, such as you might want to do when setting up a guest network.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.