How to browse wwwroot

I have a web server installed on a Microsoft server 2012 server and it is running.
When I access the server remotely using a web browser (Internet Explorer) I get the default welcome page.
I have also placed a text file and a shortcut to another folder in the wwwroot folder.
Can I browse the wwwroot folder so that I can view the wwwroot folder contents ?
I can view the contents of the text file by entering the following in the browser:

This is not what I want, I would like to browse the folder contents and get a user authentication prompt if I clicked on the link that I have placed in  the wwwroot folder.
Who is Participating?
Emmanuel AdebayoConnect With a Mentor Global Windows Infrastructure Engineer - ConsultantCommented:
I meant your apps.config.

I think I know what the issue is now, When you enable the Basic Authentication, you did not assigned the Application pool identity.

See the application pool identity configuration below

Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:

Do you mean that you want the contents of the wwwroot folder to be listed as if you are looking at folder director or you want browse the contents in the web browser?

For the authentication prompt, you will need to set up a user and grant that user at least read access to the contents that you placed in wwwroot folder. After you will need to go to iis manager to enable basic authentication

1.With a powershell command:
Import-Module ServerManager
Add-WindowsFeature Web-Basic-Auth

2. Using Graphic interface
1.  Start Server Manager
 2.  Click on "Add roles and features" from the Dashboard
 3.  Click the Next button on the Before You Begin page
 4.  Click Next button for "Role-based or featured-based installation"
 5.  Click Next for the destination server
 6.  On Server Roles scroll down to "Web Server (IIS)" and expand it
 7.  Expand Web Server again and you will see the Security option
 8.  Have everything enabled under this but if you expand Security you can select the "Windows Authentication" option to install and click Next to complete the install

How to enable basic authentication and disable anonymous authentication
1.Open Internet Information Services (IIS) Manager:
2.In the Connections pane, expand the server name, expand Sites, and then click the site, application or Web service for which you want to enable basic authentication.
3.Scroll to the Security section in the Home pane, and then double-click Authentication.
4.In the Authentication pane, select Basic Authentication, and then, in the Actions pane, click Enable.
5.In the Authentication pane, select Anonymous Authentication, and then click Disable in the Actions pane.

alcindorAuthor Commented:
I used the power shell as per your suggestion and enabled Basic authentication and disabled anonymous authentication and re-booted the server.
This resulted in total loss of my network configurations ? (no network adapter)
I had to load a snapshot from the base configuration ( I am using a virtual cloud server ).

I decided to Use the graphic interface and re-boot the server. The network configurations were not affected this time and I get an authentication prompt but when I enter a username and password, I always get Access Denied ?
I have shared C:\inetpub\wwwroot for a user that is a member of Administrators and also for the Administrator account and I get Access denied for both users.
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
You don't need to shared the folder since the iis contents are located on the same server, it should be NTFS permission of at least Read, List, and Read & Execute permissions to the wwwrootfolder. Ensure that the permissions are propagated down.

I noticed that the user is a member of the Administrators, check that the administration group have access to your wwwrootfolder.

alcindorAuthor Commented:
I have checked the access rights and all rights to wwwroot are enabled to The Administrator and to the roger Alcindor account as per the attached screen shot.
Still I get Access denied ?
I have logged in as Administrator or as WORKGROUP\Administrator with the Administrator password with the same result.
alcindorAuthor Commented:
Having also shared the wwwroot folder as wwwroot, I can access the wwwroot folder over the internet using SMB as follows:

\\\wwwroot  and can browse the folder contents.

This tells me that the user name and password I am using is correct and that the access rights are ok.

But using a web browser Http://  I still get access denied after entering the user name and password ?
Therefore the setting on the web server are suspect ?
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
Check the event viewer to see the error log, (preferably the security event log)

Also, check that there is no authentication requirements in your app settings

alcindorAuthor Commented:
There are no entries in the customviews->Server Roles->Webserver(IIS) log indicating authentication failure

There are no entries in the Windows Logs->Security log indicating authentication failure

I don't understand what you mean by "your app settings" ?
The only application that I am using is Internet Explorer 10 running under windows 7 Professional.
alcindorAuthor Commented:
Still not working but I need to spend more time reading up on application pool identity configuration and the links that you provided in your last comment. Unfortunately, I have more urgent priorities at the moment and have to defer working on this problem.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.