Unable to upload images in Wordpress on Local Host

I am unable to upload images in wordpress. I am working in a local environment on my Mac, using Xampp.  This may be an additional clue (my htaccess file is not writeable).

The error I get: "The uploaded file could not be moved to wp-content/uploads/2013/09."
deitercat2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GaryCommented:
Does wp-content/uploads/... exist?
Does wp-content/uploads/... have write permissions?
0
deitercat2Author Commented:
It does exist.  I' dont know how to change permissions via the localhost.
0
GaryCommented:
You do it directly via clicking on the folder, File menu and Get Info.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

deitercat2Author Commented:
Thanks.  The permissions were set to read and write for me, I changed the permission to read write for everyone else, but unfortunately, I'm still getting the same error. I checked the permissions for both wp content and the uploads directory.
0
subhashchyCommented:
this might work.


1 Use your ftp client to open the folders on your website.
2 Right click the wp-content folder and open "properties".
3 There you will see the chmod 775 setting. Change it to 777.
4 Do the same to the "uploads" folder.

Also go in WP settings and uncheck the box which says "organize your uploads in days/months".
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
deitercat2Author Commented:
It was the second part of your solution that did the trick for me, after unchecking the box for "organize your uploads in days/months."After I did that  it worked just fine.    Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.