Exchange services wont start

Hi there,

I have built a VPC for one of my clients using Amazon AWS

I have built a 2012 domain controller and added exchange 2013 (i know its not best practice).

I am having some problems with some of the exchange services, they wont properly start.

I am getting 2 errors in Event Viewer:

Event ID 4027 MSExchangeADAccess

Process MSExchangeThrottling.exe (PID=10028). WCF request (Get Servers for bluedogfences.local) to the Microsoft Exchange Active Directory Topology service on server (TopologyClientTcpEndpoint (localhost)) failed. Make sure that the service is running. In addition, make sure that the network ports that are used by Microsoft Exchange Active Directory Topology service are not blocked by a firewall. The WCF call was retried 3 time(s). Error Details
 An error occurred during forest discovery (bluedogfences.local). ----> No Suitable Directory Servers Found in Forest bluedogfences.local Site Default-First-Site-Name.
   at Microsoft.Exchange.Directory.TopologyService.ADTopologyDiscovery.Discover()
   at Microsoft.Exchange.Directory.TopologyService.ADTopologyDiscovery.DoWork(CancellationToken cancellationToken)
   at Microsoft.Exchange.Directory.TopologyService.Common.WorkItem`1.Execute(CancellationToken joinedToken)
   at Microsoft.Exchange.Directory.TopologyService.Common.WorkItem`1.<>c__DisplayClass6.<StartExecuting>b__4()
   at System.Threading.Tasks.Task.Execute()
   at Microsoft.Exchange.Directory.TopologyService.Common.Extensions.WrapAndRethrowException(Exception exception, LocalizedString errorMessage)
   at Microsoft.Exchange.Directory.TopologyService.TopologyDiscoveryManager.EndGetTopology(IAsyncResult ar)
   at Microsoft.Exchange.Directory.TopologyService.TopologyService.InternalEndGetServersForRole(IAsyncResult result)
   at Microsoft.Exchange.Directory.TopologyService.TopologyService.<>c__DisplayClassa.<EndGetServersForRole>b__9()
   at Microsoft.Exchange.Directory.TopologyService.TopologyService.ExecuteServiceCall(Action action)

and this one:

Event ID 2142 MSExchangeADTopology:

Process Microsoft.Exchange.Directory.TopologyService.exe (PID=6532) Forest bluedogfences.local. Topology discovery failed, error details
No Suitable Directory Servers Found in Forest bluedogfences.local Site Default-First-Site-Name..

Any help greatly appreciated.

Who is Participating?
BSRITConnect With a Mentor Author Commented:
ended up building a 2012 dc, and a separate exchange server
everything worked fine
Seth SimmonsSr. Systems AdministratorCommented:
have you tried starting the exchange topology service manually?  all the exchange services are dependent on that service

this can happen when running on a domain controller.  exchange services are trying to start but fail because AD hasn't fully started yet so it errors out when trying to query domain information.  it could also happen because it's a GC (which is required role)
BSRITAuthor Commented:
hi there, thanks for the post.

yea the ad topology service is starting fine.. the services that are stuck on starting are:

from looking at the services list, its only the exchange services that wont start.
BSRITAuthor Commented:
i fixed issue myself
I have the same issue, how did you fix it?

Thank you!!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.