Server Errore /Application

I recently created a new sharepoint 2013 solution and upgraded project files from 2007 version in visual studio 2012.

I have a link that calls a page and it is a plain .aspx page which is deployed under _layouts folder under 15 hive. It throws me Server Error/Application when calling that page. I get the description

"To enable to view the error message on a remote machine please create custom error tag and mode = 'remote only" in web.config file.

I tried changing several options like mode = "On", "remote only" and "Off" but cannot see what the details of the error. It is just plain .aspx page. How to get this resolved
bujjigaduAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rainer JeschorCommented:
Hi,
to completely disable the custom error page, you will have to adjust
multiple settings
in
two different web.config files

1. Settings
customErrors mode have to be set to "Off"
SafeMode CallStack have to be set to "true"
compilation debug have to be set to "true"

Here an example how the different nodes should look alike - but be aware that your web.configs can look differently, therefore adjust the existing elements:
<SafeMode CallStack="true".... />
<customErrors mode="Off" />
<compilation batch="false" debug="true">

Open in new window


2. web.config files
The first web.config file is in the root folder of your web application. Normally (if not configured differently) this is in
C:\inetpub\wwwroot\wss\VirtualDirectories\YOUR PORT NUMBER

The second one is the web.config within the Layouts folder:
C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\TEMPLATE\LAYOUTS\web.config

After you have done the changes you should run an IISRESET on the SharePoint server.

And one personal comment: if you could assign more points to your questions you might attract more experts as these points are the reward for helping you out and spending sometimes a lot of personal time.

Thanks and HTH
Rainer
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.