how to un-protect a crystal report?

I have a report that seems to be protected.  Not sure, because I rarely work with subreports and this thing has several sub-reports.

I have tried everything I know how to do and get nothing.  

The real problem is that fields changed field types and now the parameters all need to be strings. But I would like to try and fix it with just one subreport first, and can't get the rest of them off the report to try it!

I don't even want to attach the report because I can't get the logo off!!!!!

_Frustrated.
Becky EdwardsEpic Clarity DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mlmccCommented:
What version of Crystal?
Your tag shows CR XI.  As far as I know there is no way to protect a report in CR XI.  Even an RPT file that is read-only can be changed and saved to a new file

CR 2011 added the RPTR extension which is a protected report and supposedly there is NO way to remove the protection.  Even the developer has to have an RPT file to work on.  In fact, as far as I know, the RPTR file cannot be opened in the designer so that is probably not the issue.

mlmcc
0
James0628Commented:
Any chance the report is just set to read-only in CR?  That's under File > Report Options.

 James
0
mlmccCommented:
Good thought.  I had never noticed that option

mlmcc
0
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

James0628Commented:
mlmcc,

 I thought that was actually what you meant when you mentioned read-only.  :-)  I just wasn't reading carefully enough.


 bjrhart,

 I didn't think of this earlier, but you mentioned a subreport.  The main report and each subreport have their own "Report Options", so if the problem is that read-only setting and you want to turn it off in a subreport, you'll need to select that subreport first, and then go to File > "Report Options" to change the options for that subreport.  If you want to turn it off in the main report and all subreports, you'll have to do it separately in each one -- Select each subreport and turn off the option, then make sure that no subreport is selected and go to File > "Report Options" to get to the options for the main report.

 James
0
mlmccCommented:
You may have to actually edit the subreport to get the subreport options.

I was referring to Windows file system read-only.

mlmcc
0
James0628Commented:
Oops.  You're right. You have to have the subreport open in the editor and that tab selected, before you can change the Report Options for the subreport.  Otherwise you're just changing the options for the main report.  I wasn't thinking, I guess.

 James
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Becky EdwardsEpic Clarity DeveloperAuthor Commented:
That worked!  Thanks for all your help!
0
James0628Commented:
You're welcome.  Glad I could help.

 James
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.