Wordpress error

Greetings Experts.  My site is running WP 3.6.1 and I haven't experienced this issue before.  I brought the site up (3+/- weeks) and for some unknown reason now, when I try to upload a picture now, the "Upload Images" button doesn't perform any action.  It doesn't matter which page I am editing although I was able to upload images prior to today.  I was using Chrome when I first encountered this problem (1:15pm EST) and switched to IE to see if it was a browser issue.  Same issue there except now in the lower left-hand corner of the browser, I get an error message.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)
Timestamp: Mon, 30 Sep 2013 16:43:40 UTC


Message: 'undefined' is null or not an object
Line: 32
Char: 12259
Code: 0
URI: http://mysite.com/wp-admin/load-scripts.php?c=1&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,quicktags,underscore,backbon&load%5B%5D=e,wp-util,wp-backbone,media-models,plupload,plupload-html5,plupload-flash,plupload-silverlight,plupload-html4,json2,wp-plupload,&load%5B%5D=media-views&ver=3.6.1

I really don't know how to trouble-shoot this so I'm posting here.  I haven't used WP very long so please keep that in mind when responding.  

I've updated my PC's JAVA, Shockwave and other apps thinking that may fix it but no luck.  Since I was able to upload images last and today, I haven't installed anything on my PC like a new AV program or installed any Windows updates.

Thank you for your time!
LVL 9
samiam41Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jason C. LevineNo oneCommented:
First step to troubleshoot any WordPress problem:

1) Disable ALL plugins and try again.

Second step if step 1 doesn't work:

2) Switch to one of the generic WP themes (TwentyTwelve or TwentyThirteen) and try again.
0
Julian HansenCommented:
Open the site in chrome

Right click the page and select "Inspect Element"

Click on the Console tab

Report what you see there.

This sounds like a Javascript library error - one of your javascript pluggins is conflicting or has been updated and there is an issue.

The Chrome console should give you more information than Internet Exploder.
0
samiam41Author Commented:
Thanks for the replies.

@julianH- I didn't know about that feature in Chrome.  Here are the results:
Uncaught TypeError: Cannot call method 'replace' of undefined
load-scripts.php?c=1&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-…ight,plupload-html4,json2,wp-plupload,&load%5B%5D=media-views&ver=3.6.1:32

@jason1178- I apologize in advance but I am guessing I would disable these plug-ins from the WP admin page.  Just to confirm, do I need to do any sort of backup before I disable these?  I have never disabled a plug-in and don't want to monkey the site up.
0
Become a Certified Penetration Testing Engineer

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

samiam41Author Commented:
@jason1178- I went ahead and threw caution into the wind and disabled a plug-in, tested the upload and each failed.  I enabled the plug-ins one at a time and I got the error each time I tried to upload.  If I switch the theme, what will that do to the content that is in place now?
0
Jason C. LevineNo oneCommented:
Switching the theme won't do anything to the content (that's the whole point of themes :). You may lose a widget because it has no equivalent location in the new theme but it will come back when you switch back.

What we are checking with these two steps is to see if any introduced code is causing the conflict.  Code is introduced through plugins and through the functions.php file for the theme. Switching to a basic theme "cleans" WP.
0
Julian HansenCommented:
That looks like a JQuery error - could be anything - do you have a link to your site we can look at?
0
samiam41Author Commented:
@jason1178- Ah.  I see.  Thank you for the explanation!  My apologies for the simple questions but I like to ask before doing something I'm not familiar with.

So I changed to the twenty twelve theme.  There is no content on any of the pages but all of the pages are there.  I didn't see any of the options to upload media but did find an "Add Media" option on the Pages tab and I get the same error when I click on that.  Just to have some fun, I then changed to the twenty thirteen theme and received the same error there as well.

That leads me to wonder if there is something in my browser that would prevent it from working.  I opened up IE8 to see what would happened and same error.  So I'm not sure what I am doing wrong here or what to try next.  I'm completely game for whatever you come up with.

Thanks everyone!
0
samiam41Author Commented:
HA!!  Now that is crazy.  So I jumped into my pc at home (thank you logmein) and tried to add images to the exact same freaking page that I am trying to modify here and I was able to do it with no problems.  

I guess I will have to begin figuring out what is different from the PC I am using at the office compared to the one that I am using at home.  I did notice that I tried using IE10 at home so not sure if that makes a difference.

Any suggestions on where to start looking for what would cause one PC to work (home) versus one that won't (office)?
0
Julian HansenCommented:
Cached JS files?

Try clearing cache on both.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
samiam41Author Commented:
Ran in incognito mode as well as ctrl+shift+del and cleared out the cache.  Negative.  Maybe an older version of Java?  Live 7u21?
0
Jason C. LevineNo oneCommented:
Cached JS files?

Try clearing cache on both.

Sounds like it...
0
samiam41Author Commented:
Thanks for your help and time with this.  While I haven't solidly identified the issue, a new, critical issue has come up that will drastically limit how much time I will be able to spend on this.  Rather than keep you guys bobbing in the sea of suspense, I am awarding points and closing this question out.  Again, I appreciate it immensely and hope to work with you all again soon.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.