Testing RPC/HTTP connectivity - Exchange 2007

Users are reporting being unable to connect to the Exchange server whilst away from the office via MS Outlook.
Inside the office, through OWA, and via iPhone its OK

Doing a test on www.testexchangeconnectivity.com returns the following error,

Testing HTTP Authentication Methods for URL https://remote.myclient.com/rpc/rpcproxy.dll?KL-HQ-SVR-01:6002.
 	The HTTP authentication test failed.
	Additional Details
 	A Web exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown.
Headers received:
Connection: close
Content-Length: 326
Content-Type: text/html; charset=us-ascii
Date: Tue, 01 Oct 2013 08:42:32 GMT
Server: Microsoft-HTTPAPI/2.0

Open in new window

Any ideas?
Who is Participating?
MAS (MVE)Connect With a Mentor Technical Department HeadCommented:
Please type this command and check it pass or no.
 If this is ok try switching to basic authentication

RPCPing.exe –t ncacn_http –o RpcProxy=<the external host name of Outlook Anywhere> -u=10 –a connect –v 3 –E –R <HTTP Proxy Server or none> -P “username,domain,password” –H 1 –F 3 –b
MAS (MVE)Technical Department HeadCommented:
Please check this

Please check whether you can connect your outlook through HTTP/HTTPs from internal network
cgruberAuthor Commented:
by: abbasifttPosted on 2013-10-01 at 19:56:01ID: 39535958
Please check this

This refers to ActiveSync not RPC/HTTP.
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

cgruberAuthor Commented:
Please check whether you can connect your outlook through HTTP/HTTPs from internal network
Yes it works
cgruberAuthor Commented:
Invalid switch: -t
 Invalid switch: ncacn_http
 Invalid switch: -o
 Invalid switch: RpcProxy=remote.kabolawyers.com
 Invalid switch: connect
 Invalid switch: -v
 Invalid switch: 3
 Invalid switch: -E
 Invalid switch: -R
 Invalid switch: none
 Invalid switch: -H
 Invalid switch: 1
 Invalid switch: -F
 Invalid switch: 3
 Invalid switch: -b
 Cannot parse security package id : -a
Simon Butler (Sembee)ConsultantCommented:
Has it ever worked?
Does Autodiscover work?

Usually the quickest way to deal with this is to disable Outlook ANywhere, wait 15 minutes for the disable to be logged, then enable it again. If that doesn't work, you will need to remove the RPC proxy feature and reinstall it. Remember to run IIS RESET in between.

cgruberAuthor Commented:
its worked before yes.
cgruberAuthor Commented:
reinstalled RPC, same issue.
MAS (MVE)Technical Department HeadCommented:
In your post#39538057 you mentioned it is working from internal network

Can you see HTTP or HTTPs  when you open outlook connection status from internal network

type this command to open outlook with connection status

outlook.exe /rpcdiag

if you can see HTTP/HTTPS from internal network
then it is your firewall issue.
Please make sure port 80 and 443 is open

Here to check teh connection status

Tick the below options to force outlook to use HTTP from internal network (attached scnshot)
"On fast networks, connect using HTTP first, Then connect using TCP/IP"
"On slow networks, connect using HTTP first, Then connect using TCP/IP"
cgruberAuthor Commented:
Switching to Basic Authentication fixed the issue. Thanks
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.