Testing RPC/HTTP connectivity - Exchange 2007

Users are reporting being unable to connect to the Exchange server whilst away from the office via MS Outlook.
Inside the office, through OWA, and via iPhone its OK

Doing a test on www.testexchangeconnectivity.com returns the following error,

Testing HTTP Authentication Methods for URL https://remote.myclient.com/rpc/rpcproxy.dll?KL-HQ-SVR-01:6002.
 	The HTTP authentication test failed.
 	
	Additional Details
 	A Web exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown.
Headers received:
Connection: close
Content-Length: 326
Content-Type: text/html; charset=us-ascii
Date: Tue, 01 Oct 2013 08:42:32 GMT
Server: Microsoft-HTTPAPI/2.0

Open in new window


Any ideas?
cgruberAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution Guide - Technical Dept HeadCommented:
Please check this
http://msexchangeguru.com/2012/02/01/exchange-activesync/

Please check whether you can connect your outlook through HTTP/HTTPs from internal network
0
MAS (MVE)EE Solution Guide - Technical Dept HeadCommented:
Please type this command and check it pass or no.
 If this is ok try switching to basic authentication

RPCPing.exe –t ncacn_http –o RpcProxy=<the external host name of Outlook Anywhere> -u=10 –a connect –v 3 –E –R <HTTP Proxy Server or none> -P “username,domain,password” –H 1 –F 3 –b
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cgruberAuthor Commented:
by: abbasifttPosted on 2013-10-01 at 19:56:01ID: 39535958
Please check this
http://msexchangeguru.com/2012/02/01/exchange-activesync/

This refers to ActiveSync not RPC/HTTP.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

cgruberAuthor Commented:
Please check whether you can connect your outlook through HTTP/HTTPs from internal network
Yes it works
0
cgruberAuthor Commented:
Invalid switch: -t
 Invalid switch: ncacn_http
 Invalid switch: -o
 Invalid switch: RpcProxy=remote.kabolawyers.com
 Invalid switch: connect
 Invalid switch: -v
 Invalid switch: 3
 Invalid switch: -E
 Invalid switch: -R
 Invalid switch: none
 Invalid switch: -H
 Invalid switch: 1
 Invalid switch: -F
 Invalid switch: 3
 Invalid switch: -b
 Cannot parse security package id : -a
0
Simon Butler (Sembee)ConsultantCommented:
Has it ever worked?
Does Autodiscover work?

Usually the quickest way to deal with this is to disable Outlook ANywhere, wait 15 minutes for the disable to be logged, then enable it again. If that doesn't work, you will need to remove the RPC proxy feature and reinstall it. Remember to run IIS RESET in between.

Simon.
0
cgruberAuthor Commented:
its worked before yes.
0
MAS (MVE)EE Solution Guide - Technical Dept HeadCommented:
0
cgruberAuthor Commented:
reinstalled RPC, same issue.
0
MAS (MVE)EE Solution Guide - Technical Dept HeadCommented:
In your post#39538057 you mentioned it is working from internal network

Can you see HTTP or HTTPs  when you open outlook connection status from internal network

type this command to open outlook with connection status

outlook.exe /rpcdiag

if you can see HTTP/HTTPS from internal network
then it is your firewall issue.
Please make sure port 80 and 443 is open

Here to check teh connection status
http://office.microsoft.com/en-001/outlook-help/verify-connection-to-exchange-through-the-internet-HP001036394.aspx

Tick the below options to force outlook to use HTTP from internal network (attached scnshot)
"On fast networks, connect using HTTP first, Then connect using TCP/IP"
"On slow networks, connect using HTTP first, Then connect using TCP/IP"
image-thumb4.png
0
cgruberAuthor Commented:
Switching to Basic Authentication fixed the issue. Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.