Backup Exec fails with Endpoint

If I turn off endpoint (smc -stop) on a workstation and run a backup from our server where endpoint console is installed it will work just fine but when it is turned on it will fail. The error message says The job failed with the following error: A communications failure has occurred. What can I change on endpoint to make Backupexec work? And if possible can it be done remotely or via psexec, if not it's ok.
LVL 2
stlhostAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ron MalmsteadInformation Services ManagerCommented:
You can run a command line with psexec \\machinename "smc -stop" as long as the backup server has rights to do so.. or provide the credentials to psexec.. and configure this as a pre-job command line in the backup job properties.  Then add a post job command line to turn it back on.

Either that.. or create a scheduled task on that server, to turn off the service a minute or so before the scheduled backup time.. then turn it back on later...(however the time will be uknown)

I prefer the psexec method.

Another option may be to add some exclusion to the firewall for the Backup Exec service process.. (either the port it uses, or the executable program), but i'm not familiar with your firewall software.
0
stlhostAuthor Commented:
What would be the exclusion specifically the Agent I guess?
0
Ron MalmsteadInformation Services ManagerCommented:
The exclusion would be the backup exec service process. (yes, the agent)
If you right click "My Computer", click manage.. browse to services..
Go to the properties of the Backup Exec Agent service.. the executeable name/path will be shown.

Most likely it's the firewall exclusion you need, but you should also exclude it from realtime scanning for performance reasons.

btw-  It's usually a good idea to disable realtime scanning while the backup job is running anyway.. again.. for performance reasons.  Each time the agent tries to access a file, the realtime scan engine will likely attempt to scan it first..
0
stlhostAuthor Commented:
Adding the program to the exclusion list didnt help. If I add the command smc stop it works but this leaves the computer vulnerable unfortunately. What would the exception type be?
0
Ron MalmsteadInformation Services ManagerCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.