• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4812
  • Last Modified:

Unable to delete emails in OWA exchange 2010

I'm seeing an error when trying to delete a message through OWA.

"The action you tried to perform couldn't be completed because there's a configuration problem on the server. If the problem continues, contact your helpdesk. The entire error report is listed below..." (listed below is the same text as shown here)

The problem appears when we try delete email in OWA from outside.
Light version and internally it works fine.
No host in bindings

Also there is event ID 108
  • 2
1 Solution
Simon Butler (Sembee)ConsultantCommented:
What service pack is Exchange 2010 on? Is it being accessed directly, or are you publishing Exchange with another tool?

Sumit GuptaSystem and Virtualization EngineerCommented:
I have seen a similar problem on some reference sites and here is one solution that worked for them and you can also try the same:

We noticed in the meantime that this problem only occurred with some users. After analyzing the users we found that they were members of an unusual number of groups, which led us to these posts:



and this MS KB http://support.microsoft.com/kb/970875


We therefore created the MaxFieldLength and MaxRequestBytes keys under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters and increased their sizes incrementally. This cleared up approximately 90% of the errors.

We finally noticed that the remaining errors coincided with log entries in the IIS logs similar to: POST /ews/exchange.asmx - 443 - OwaProxy 401 1 2148074254 15

Another 400 error, this time in the EWS connection attempt, Google found this post:


We noted that the <customBinding> section of the web.config under c:\Microsoft\Exchange Server\V14\ClientAccess\exchweb\ews\ actually has a maxBufferSize="81920" setting. We increased this value as well and so far all of these errors have disappeared.

Our interpretation: If users are in too many Security groups, their token size increases so much that the header becomes too large to be processed, necessitating the above changes. Curious, but logical that both the OWA and the EWS directory access where impacted, though the reference to a "configuration error" led us to spend hours on reviewing our OWA configuration.
Sumit GuptaSystem and Virtualization EngineerCommented:
And also try this KB article from Microsoft which can fix your problem:


Consider the following scenario:
You use Outlook Web App (OWA) to log on to a Microsoft Exchange Server 2010 mailbox.
You try to perform one of the following operations:
-Delete an email message.
-Mark an email message as read or unread.
-Right-click a folder, and then click Empty Folder.
-Upload an attachment.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now