Windows 2008 Terminal Server displaying "Other User" on login

Hi,

We have a Terminal Server that we're deploying for users to login to and use a specific application.  This is a Windows 2008 R2 box that is replacing a Windows 2003 server.  On the Windows 2003 TS the users are presented with the computer disclaimer and then a username and password login prompt after clicking OK.

On the Windows 2008 R2 TS after accepting the disclaimer they are then presented with two buttons - one to login as themselves and another that is titled Other User.  I would like to remove the second button and simply display the username and password login similar to Windows 2003.

I have tried the following GPO settings without much luck

Computer >  Policies > Admin > System > Logon
  - Hide entry points for Fast user Switching
  - Alwanys use classic logon (Looks to only work with computers not on the domain)

Computer >  Policies > Windows > Security Settings > Local Policies > Security options
  - Interactive logon: Do not display last username (Enabled)
  - Interactive logon: Do not require CTRL+ALT+DEL (Disabled)

Sort of running out of ideas and would be great if someone might be able to suggest something.  I haven't found anything under the RDP section in GPO's that even remotely sounds right either - thought I would mention that as on the server console it comes up as required.

Thanks,
Dave
biggles70Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strivoliCommented:
Are you talking about what is shown below?

Capture
0
biggles70Author Commented:
The attached file shows the screen that I am referring too. I don't have an issue with it, but the application guys are keen on the Other user being shown.  

From what I can gather to get rid of it would mean that the user would need to login to the workstation with the same user that they want to login to the TS or go the long way around to change.
Login.JPG
0
Kent DyerIT Security Analyst SeniorCommented:
Maybe you need to be sure you the policies are updated..
GPUPDATE /? from command prompt..

I think the one you want is - GPUPDATE /FORCE
0
strivoliCommented:
AFAIK there's no way to hide the "Other User" option.
W2003 and W2008R2 behave differently under many aspects... this one is one of them.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
biggles70Author Commented:
I had run gpudate /force rebooted and checked the result etc and still no luck. I have looked everywhere as well and can't find anything in reklation to removing the other user option.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.