Disk drive questions

Hello,

i'm looking for an exact answer to following questions :

in windows 7, i always saw all drives when connected automatically.
all of a sudden -  they are not seen anymore, and i have to assign a drive letter; then all is ok

1-   WHY do i now need to assign a drive letter - and not before?  (for the same disks?)
all disks are healthy, and connected to sata ports

2-  Can i reset the system so it recognises the disks again automatically ?  if yes  - HOW ?

Don't suggest system restore, sfc scannow, or system repair (they are not the solution)

i hope you can clear this up
LVL 94
nobusAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DavidPresidentCommented:
Drive letters can spontaneously disappear in windows.  This can happen if you change the boot order by moving cards around on your motherboard, or install drivers for new equipment.

Sometimes it happens because of software bugs.

If a HDD isn't showing up then run disk administrator and right click the device.  Add a drive letter that isn't being used.  Ideally use the same letter that you were using before
0
nobusAuthor Commented:
dlethe (you're one of the people i like on this question) - are you saying that there is no clear reason? or fix?
that would be a bummer.
yes i connect and disconnect a lot of drives on this pc - it's my test pc
but why did it work fine before??
0
Kruno DžoićSystem EngineerCommented:
OS will recognize hdd on same letter only if it's connected to the same port and on first plug you gave him unused letter
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Kent DyerIT Security Analyst SeniorCommented:
Is this a CD Drive?  There is a known issue with XP (maybe 7) with keeping the CD drive available..

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/cannot-re-enable-cd-rom-drive-on-windows-7-64x/73391727-6968-4b82-853e-0df03fc378dc
0
nobusAuthor Commented:
M3rc - are you sure about that?  i don't remember exactly, but i thought it worked fien for a long time
kdyer - i'm talking about disk drives.
0
JohnnyCanuckCommented:
Maybe automount has been disabled.  Open a command prompt as administrator and type
diskpart
then type
automount
It should say "Automatic mounting of new volumes is enabled.".  If it doesn't then type
automount enable
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gary CaseRetiredCommented:
I assume you're referring to removable drives -- not to the fixed internal drives .... is that correct?

If so, then what's likely happened is that you have had different drives that were assigned to the same letter ... and subsequently have attached a drive that wasn't the most recent drive to receive that letter.    e.g. if you plug in a drive and it's assigned F:,  then later plug in a 2nd drive that's also assigned F: (after the first one was removed);  then plug the first one back it, it "wants" F:, but it's not available, so it doesn't get assigned a letter.

If the set of drives you plug in is fixed, you could plug them in one-at-a-time and manually assign a letter with disk management - being sure every drive had a different letter;  then in the future whenever you plugged one it, it would get the same letter it had been previously assigned.

If you have too many drives to do this; or if the set of drives you use varies; then I'd assign "high" letters to those that you consistently use (S:, T:, U:, V:, etc.), so that other drives are assigned the lower letters when you use them.

Also, be sure you ALWAYS do a "safely remove", which not only ensures there are no uncommitted buffers for the drive; but also frees up the drive letter it was using.
0
Kruno DžoićSystem EngineerCommented:
that is the same thing as with USB drives, I think :)
0
nobusAuthor Commented:
Garycase, thanks for joining here - i posted :  all disks are healthy, and connected to sata ports
as for removal - i connect them with the power OFF - no safer removal exists afaik
i already tried using upper letters, but it does not help
more info: (in case it helps)
this system (P5Q-VM board) has 6 sata connecters + 1 IDE connector, 1 for OS disk, 1 for CD drive (these stay)
i use the 4 others for connecting all sorts of drives for repairs + i have 2 2TB  disks (1 for backups, 1 for images)
0
nobusAuthor Commented:
Johnny Canuck - i just tried automount - and it was disabled, so i enabled it
it seems to work again
i'll test it further today and post results later
0
Gary CaseRetiredCommented:
"connected to sata ports" doesn't mean they're internal -- they could be eSATA or internally connected but in hot-swap cages.    My question was whether or not they were removable.

But it sounds like that's not the issue -- clearly you somehow managed to disable automount, so that was the simple fix to this issue.
0
nobusAuthor Commented:
yes, Garycase, the disks are all internal
i just wonder how it could become disabled?  any ideas about that?
0
DavidPresidentCommented:
Drive letter ordering isn't carved in stone.  It is determined by the BIOS at POST time.  If a particular HDD is late to spin up (run diagnostics), then it can also result in losing drive lettering.

This is also not specific to windows.   If you were running a *NIX O/S, then   it is possible the same HDD could be /dev/sdb at one boot, and /dev/sda at another.    

If you haven't messed with drivers or been inside the enclosure then run diagnostics on all target devices.  If they pass and this is the first time it happened, then just move on and chalk it up to a bug. You'll never find root cause.   Sorry, but that is just the way it is.
0
JohnnyCanuckCommented:
I can't say how automount became disabled.  Perhaps you booted a drive that disables it, either by policy or some kind of malware.
0
pgm554Commented:
Ya know Vmware can turn off automount if you were running it on your system.
0
nobusAuthor Commented:
ok guys, my question is answered
thank you all, and of course the cigar goes to Johnny
0
nobusAuthor Commented:
a nice crisp solution !
Thanks for that Johnny
0
JohnnyCanuckCommented:
You are welcome!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Hardware

From novice to tech pro — start learning today.