Adding XenApp Farm to Web Interface 5.4

Hi All,

I am installing a new XenApp 6.5 Farm on Windows 2008R2. I installed Xenapp as usual. I could publish the application normally.

We have another two XenApp farms (4.0) and 5.0 running on Windows 2003 Server.

They are connected to WI+CGS. Now I connected the new farm to same web interface.

Here is the process I followed to connect the farm on WI+Citrix Secure Gateway server.
1. opened the Citrix Web Interface Management console

2. Rt Click> Server Farm> Add> Put farm Name>Add>Added Server ip add>Change XML port to 8080>OK>OK

3.Highlight the sitre name>Secure Gateway Access>AccessMethod:Gateway Direct>Added the STA url as http://server_IP:8080/scripts/ctxsta.dll> Finish

4. Checked the Event ID: Shows "Site path: c:\inetpub\wwwroot\Citrix\XenApp.

The configuration data was reloaded successfully. [Unique Log ID: af17c4a7]"


5. Launch the gateway url from a user machine. Published application along with Old farms App are visible.

6. Now When I try launch the app published from new Farm. it shows "An error occurred while making the requested connection. "

7. On the Eventlog of the WI server, i get a error stating that "The Citrix servers reported an unspecified error from the XML Service at address http://ServerIPAdd:8080/scripts/wpnbr.dll [com.citrix.xml.NFuseProtocol.RequestLaunchRef]. [Unique Log ID: 17c26926]"

8. Where I am commiting mistake?

My old farm applications are running fine.


Getting mad as I have done this atleast 20 times.......................Please help!!!
bubaibhattaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ayman BakrSenior ConsultantCommented:
On your new farm 6.5 servers run elevated CMD and run:

Ctxxmlss.exe /U

Press enter, then run

Ctxxmlss.exe /R8080
0
bubaibhattaAuthor Commented:
Thanks, Mutawadi,

it showserror
0
bubaibhattaAuthor Commented:
my mistake, i did re-registered xml.

But same end result


Here is the new result in WI

The Citrix servers reported an unspecified error from the XML Service at address http://SERVER FQDN:8080/scripts/wpnbr.dll [com.citrix.xml.NFuseProtocol.RequestLaunchRef]. [Unique Log ID: 74da684]
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Ayman BakrSenior ConsultantCommented:
I suspect that your XenApp 6.5 farm is not set with XML port 8080.

When I asked you to run Ctxxmlss, I specifically said to start elevated cmd (that is run with admin account for the farm). You should do this on all your xenApp servers having both the controller and session host roles.
0
bubaibhattaAuthor Commented:
I removed all the servers from the farm except one.

I did re-registered ctx xml on port 8080 as per you. and now it trying to launch an app.

I also connected to that server via RDP.

What happens now is that whenever there is a application trying to launch, I see that RDP to that server is getting disconnected. App also is not launching.  


What should I do now?
0
Ayman BakrSenior ConsultantCommented:
Do you have Hotfix Rollup Pack 1 installed on XenApp 6.5?

If not, then either install Hotfix Rollup Pack 1 or install limited hotfix release XA650W2K8R2X64015 and check if this resolves your issue.

Hope this helps.

One more question out of curiosity: have you enabled pass-through authentication on the web interface site?
0
bubaibhattaAuthor Commented:
No, on both questions. I tried to install that one as well, but it failed to install. I uninstall XenApp from the box and planning for a fresh installation.


In our WI, it is explicit authentication is enabled.
0
Ayman BakrSenior ConsultantCommented:
OK, let's see how it goes after installing the hotfix rollup pack 1. Remember - it is best to do the installation in the following order:

1. Windows 2008 R2
2. XenApp 6.5
3. Windows patches and latest updates
4. XenApp 6.5 hotfix rollup pack 1 and later hotfixes
5. If it is a VM then install the hypervisor integration software
0
bubaibhattaAuthor Commented:
Thanks Mutawadi for that valuable information.

I did re-install the whole thing and this time it went flawless. I think, however not sure, that in earlier case there were some SQL 2012 installed on that server.

This time I installed XA 6.5 Feature Pack 2.

Can you tell me what are the hotfixes that I need to install before sending it to production?

I didn't understand specifically "hypervisor integration software" specifically. Yes all the servers are on VMWare ESXi.

One special mention that I need to do here: You have been always very helpful and always helped me pinpointing the right direction. Thanks a lot from the bottom of my heart!!!!!
0
Ayman BakrSenior ConsultantCommented:
SQL on XenApp? Very bad idea!!

Feature Pack 2 installs latest features and benefits, but not latest hotfixes. To install latest hotfixes you will need to install XenApp 6.5 Hotfix Rollup Pack 2.

Hypervisor Integration Software provides Windows drivers and guest agent for the virtual machines. They replace emulated or legacy storage and network drivers with para-virtualized drivers resulting in high-speed storage and network performances. In addition to that the guest agent provides integration between the hypervisor system, the console from which you manage the system (this is XenCenter for Citrix XenServer) and the guest VM which will allow task such as force shutdown, rebooting and starting up etc...
For VMWare ESXi the hypervisor integration software is called VMWare Tools. So ensure that the VMWare Tools are installed in your VMs.

It is my pleasure ;)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bubaibhattaAuthor Commented:
Thanks Mutawadi,

Just installed XenApp 6.5 Hotfix Rollup Pack 2.

Everything is fine now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.