Sharepoint 2010 open office files - one click

We recently upgraded to Sharepoint 2010 Foundation, users navigate to a shared document folder, click on a Office 2010 Word document and the it tries to open in a browser, which would be okay if it actually opened but we get "Word Web App cannot open this document due to an unknown error", that started when the site was recently moved to another server.

They want to click and open in Word itself, instead they must use the drop down to the right of document and select "Edit in Microsoft Word", then the site gives a popup - Message from webpage: Some files can harm your computer, if the information looks suspicious etc.  after which they click ok and get the document.

How do I:

1.turn off/on opening in web page?
2. Enable users to click the document once and get it.
tcinfoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

colly92002Commented:
You just need to disable the Office Web Apps feature.

Full instructions on doing this (in several different ways) available here:
http://technet.microsoft.com/en-us/library/hh230314%28v=office.14%29.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tcinfoAuthor Commented:
In this case navigating to and following from the above technet:
Deactivate the Office Web Apps feature
To deactivate the Office Web Apps feature on a single site collection by using Site Settings

    Verify that the account that you use to perform this procedure is an administrator for the site collection.

    In a supported browser, open the SharePoint site, click Site Actions, and then click Site Settings.

    On the Site Settings page, in Site Collection Administration, click Site collection features.

    On the Features page, for Office Web Apps, click Deactivate.

I found Web Apps was not Activated, but neither was Open in Client application, turned that on and they open fine except it prompts whether to edit or read only version, is there setting for that as well?
0
colly92002Commented:
Have you got check-in/out enabled on the list?  If so then if a document extension is a MS application then it will open read only if you click on teh doecument and read-write if you choose "edit" from the context ment.
0
tcinfoAuthor Commented:
I noticed if a user is running the 64bit version of IE it still tries to open with the Web App feature, even though in Central Admin it's not listed as Activated.

Am I missing something? (Besides getting users to run 32bit IE).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.