Browsing Hangs After Site Comes Onto Domain

We have a branch office that we just added to our domain and once we added them users started to complain about internet pages that hang then crash. It is intermentent but it happens enough to raise large concern. The site has a 2008 server for DC and a brand new sonicwall. How would I begin to troubleshoot something like this?
portillosjohnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SandeshdubeySenior Server EngineerCommented:
Ensuer that correct dns setting is set on DCS and clients as this http://abhijitw.wordpress.com/2012/03/03/best-practices-for-dns-client-settings-on-domain-controller/

Verify the health of new dc by dcdiag /q and repadmin /replsum and post the log.Check the event log on DC and clients for any errors and warning and post the same.Ensure that firewall is not causing the issue,you can run network trace to check the same.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.