Server 2003 network conection stopped working

I have a 2003 SBS server the network connections aren't working. There are 2 connections and I've tried both. They both show up and there are no errors but I cannot ping the server or from the server ping anything. I've tried different network cables and a different switch even plugging the serve rinto the firewalls switch ports. It detects a cable there but I can't communicate with anything. I've tried deleting and reloading the drivers for the network interfaces with no luck. I can't find any problems but it still won't work.
Axis52401Security AnalystAsked:
Who is Participating?
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Please make sure you add the following reserved ports (as per the MS KB Article) to the registry and reboot the server, then see if the network works normally afterwards.

This is a common SBS problem that drove me mad many a time on the ones we managed.

Esteban BlancoPresidentCommented:
Do the NIC's have static IP's?
SteveIT ManagerCommented:
make sure if you haven't already that you have the correct manufacturer drivers

boot into safe mode with networking and run some diagnostics - give one network card a static ip then plug it into a switch

plug another pc on the same ip range onto the same switch and try ping

disable windows firewall and antivirus for this test

also try an actual network card separate to those that are in your machine at the moment to help eliminate the options/causes of the problem

finally logon as a different user in case that is causing issues
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.