IISAPPPOOL configured but still accessing using IUSR

I am about to start migrating sites from one Windows 2008R2 to another and hit an issue. I have a new site and new Application Pool configured both identical (imported) from the old server. The Application pool is configured to use Application Pool Identity and have given the relevant area NTFS permissions for this user (IIS AppPool\name) user but I am getting access denied. When I use Procmon I see that the site is trying to use IUSR instead. I have checked and rechecked the obvious, created a brand new site etc and still get the same error. I could give IUSR permission, but would prefer all sites to run under their own user accounts.

Any ideas?
StuartBowenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
On the Application content folder, ensure that the you check the NTFS permission for IIS AppPool\name to propagate down to the child object

http://technet.microsoft.com/en-us/library/dd163542.aspx

Regards
0
StuartBowenAuthor Commented:
iis apppool\sitename has full permissions at the moment to the folder, all sub folders and all files in the site. Also when I look at Procmon, it is definitely trying to use IUSR user and not the App Pool user.
0
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
I see

There is an issue around how your Application pool identity was configured.

I know you must have done this already, check again the way you configured the application pool on the server you are migrating from, also compare the app.config from both servers

See the application ool identity configuration below

http://stackoverflow.com/questions/5729264/what-are-all-the-user-accounts-for-iis-asp-net-and-how-do-they-differ
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
StuartBowenAuthor Commented:
I have also created a brand new site (not an import) and used the defaultapppool on this and get the same error. It is trying to use IUSR despite the identity being set to apppoolidentity.
0
StuartBowenAuthor Commented:
Ahhhhh. As well as configuring Apppoolidentity there I needed to set the Authentication in the site to use ApplicationPoolIdentity.

I might actually make progress today.

Thanks, it is working now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.