Vmware view printer

We are working with a client that has a VDI image that we are trying to load a couple of USB drivers for them.   They are for a scanner and a Pitney Bowes LPS-1

They show up on the gold image just fine.   We created a manual pool and installed the drivers.   When I rolled out 10 of them today they all failed to load the drivers for the scanner and the Pitney Bowes so I had to go to each machine and touch them manually.  Not very productive.

Any thoughts?
MainSail2007Asked:
Who is Participating?
 
coolsport00Connect With a Mentor Commented:
Wow...well, thanks for the update. Good to know. Yeah..thought the ThinApp (View Agent/ThinPrint) services really were required.

Best regards,
~coolsport00
0
 
coolsport00Commented:
So, are you using that 'main' VM as a template, then creating a pool of VMs from that parent/template? Yes, those 'child' VMs (the pool created from that template/parent) should have the drivers you loaded to it also applied to the pool of VMs. That's odd it doesn't work. There's really nothing 'in between' there. The pool of VMs are identicals of the parent/template used.

Just as a test, make an exact copy of that parent VM that you installed the drivers on & it worked from. Then, from that VM, power it off, take a snapshot, then create a Linked-Clone Pool consisting of just say 3 VMs for now. See if the scanner, etc. works from the Linked-Clone Pool VMs. Post the results

Regards,
~coolsport00
0
 
MainSail2007Author Commented:
Thanks Coolsport
I did a manual pool and the printer and the drivers where there and worked just find.

I installed the agent minus THIN PRINT and nothing on the test vm

I installed the thin print solution although it should not apply and printers showed up but the application written in VB6 slowed down.

Not sure how to get around this other than possible using thinapp??
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
coolsport00Commented:
You have to have the Thinprint service running or it won't work. Thinprint, from my recollection, is not a separate install...when you install the View Agent, it gets installed as part of the whole pkg. For any print type device to work, you must have Thinprint installed & working.

~coolsport00
0
 
MainSail2007Author Commented:
Thank you for the suggestion but if I install the THIN PRINT the VB program stops running.  i am in a catch 22 and don't know another way to resolve
Is there a script people might use??
0
 
coolsport00Commented:
I see...

Hmm...I have not heard of anything, or seen anyone use any script. At this point, it might be your best bet to get with VMware support to see what they say/suggest.

~coolsport00
0
 
MainSail2007Author Commented:
Thank you Coolsport00 - I reached out to VMWARE and they refused to help on the issue stating that the software manufacture of the VB6 software product that is used throughout the organization needs to contact them and or upgrade the product to a compatible software platform.   THe other suggestion was using THINAPP

They threw up their hands with the Pitney Bowes since the hardware is no longer mfg by the Pitney and the program  Reference Number Label Creator is also too old.  
This is just a bad VDI project all around
0
 
MainSail2007Author Commented:
has anyone seen any improvement in the new 5.3 with printing?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.