USB Headset Driver Issue

I have a Sennheiser USB PC 8 Headset, which I use all the time on my Windows 7 x64 machine. Occasionally I have to unplug the device for whatever reason and when I re-insert it, windows moans that it cannot find a driver for it.

Usually, plugging it in to a different USB port, and/or restarting the machine will cure this problem, but not today.

I have tried the headset in other machines in the office - they all install fine. I have also tried two of my colleague's headset's in my machine and they too come up with the No Driver Found message.

error
I have also tried the Sennheiser Firmware Updater on another machine, but this offered no updates.

I have also tried removing the device from Device Manager and re-scanning. This finds it again, but same issue.

I am guessing that my pre-configured driver folder location that windows reports it is checking (after having consulted Windows Update) is perhaps not correct. How would I check, a) what mine is set to, and b) what it should be?

Many thanks in advance.
LVL 1
JedNebulaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pramod UbheCommented:
i am suspecting that USB is being blocked on your PC, is there any antivirus which might causing this? try disabling it and see if that helps.
0
JedNebulaAuthor Commented:
I have ESET NOD32 AntiVirus 6 Installed. No joy when I disable that I'm afraid, but thanks for the reply.

Windows know what the device is as it correctly labels it, it just struggles to find the drivers, which are already installed.
0
JedNebulaAuthor Commented:
I've sorted it.

I asked my colleague with a similar Windows 7 x64 machines to share his windows\inf folder. I used a utility called GoodSync to compare this with mine. It found thousands of files with differences, as you might expect.

I just copied over any files that I didn't have at all. There were 19 in total. I'm not sure which one of the 19 it needed in the end, but after they copied over, the drivers just went in fine. Didn't even need to restart.

The missing file list
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

JedNebulaAuthor Commented:
so glad it's working now.
0
TheEnd-Commented:
The solution you posted worked! I use Ventrilo (VoIP software) daily for 8 or more hours. I was tired of my old Logitech headsets dying after 6 months (the build quality isn't exactly great on them). So, I splurged and bought a Sennheiser SC 30 USB CTRL headset. I wanted a headset that was monaural because I only need it for voice, and nothing else - the SC 30 fit that need perfectly, and I couldn't find a mono headset that was better.

Sennheiser doesn't (for some weird reason) provide drivers for this or their other headsets on their website. I have no idea why. I've never seen that before.

I plugged the headset into my main PC when I got the headset in the mail yesterday, and it didn't work. Driver installation failed. I did some basic troubleshooting, nothing seemed to work. Too lazy to do the last resort of restarting my PC, I just plugged it into my laptop to see if it was indeed either a bad headset or the PC. It worked! On the laptop. So, later on, I reset my main PC. The drivers installed fine thereafter.

However, this morning, I didn't want the headset in the USB port I had it in, I wanted it in a different one. I switched USB ports, and bam - I had the same problem as above. Driver install failed. I tried everything: system restore, manual driver install, removed the drivers and re-scanned for them, tried multiple USB ports... nothing!

I will note though, you don't really need to setup "GoodSync" to do all of this; all I did was copy the entire "INF" folder (C:\Windows\inf) to a flash drive. Plugged flash drive into my main PC, copied entire INF folder into my current one. I skipped all existing files. Apparently, I was somehow missing ~200 (or so) files from the folder. I uninstalled the headset once more, re-scanned again, and boom! Headset found, and drivers installed!

Nothing explains how happy I am. I've been fixing PCs and troubleshooting problems for years. This was certainly a new & strange one for me. One that was INCREDIBLY hard to find a solution for since the setup was so unique. I was troubleshooting for nearly 5 hours straight trying everything.

Thank you for the solution!
0
JedNebulaAuthor Commented:
Many thanks for the feedback. It's always nice to know a solution worked for someone else too.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.