The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.

Hi All,
We have server with following installable:

1.Winsdows server 2012
2.IIS 8
3.MS Office 2013
4.Also the App pool is enabled for 32 bit applications

But still we are facing the following issue while uploading a 32 bit excel file from client machine:

"The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine."

The application is basically take the excel file as input and store it on server for further processing. We are getting this issue when we initialize the connection string for excel.

Need help on urgent basis....
Thanks in Advance
giveindiaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vikram Singh SainiSoftware Engineer cum AD DeveloperCommented:
Hi,

Link:

HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered"

There are solution suggested by author. And I am sure one of them will work for your case too.

By the way can you please share your connection string with us?
0
giveindiaAuthor Commented:
"Provider=Microsoft.ACE.OLEDB.12.0;Data Source=" + path + ";Extended Properties=Excel 12.0;";
0
Vikram Singh SainiSoftware Engineer cum AD DeveloperCommented:
Can you please test this:

//HDR=ColumnHeader,IMEX=InterMixed

"Provider=Microsoft.ACE.OLEDB.12.0;Data Source=" + path + ";Extended Properties=Excel 12.0;HDR=Yes;IMEX=1";

and share your results with us ?

What is the excel file version ? Is it created in 2010 or 2013 ?
0
giveindiaAuthor Commented:
We created a different application pool and set the enable 32 bit option to false. That seemed to do the trick.

Thanks,
Aditya
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
giveindiaAuthor Commented:
We created a different application pool and set the enable 32 bit option to false. That seemed to do the trick.

Thanks,
Aditya
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.