can't view website internally

So we have a hosting company that host our website. The ip address/dns name stays the same.

DNS internally and externally for the website www.test.com is the same. I check our internal dns and we have an A record for it.

Ping response shows the same ip address. Everything match up. The website works fine externally but resort to test.com instead of www.test.com.

This was a wordpress migration, just basically a wordpress theme migration, but same URL and all that. The wordpress migration was done on the same server

I check everything, all I can think of now is wordpress issues.
LVL 1
uscostAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

netcmhCommented:
Does your A record point to www.test.com or test.com?
0
uscostAuthor Commented:
yes, it does. it points to www.test.com

no ip address has been change, everything is still the same.
0
netcmhCommented:
What's between your computer and this website? Is there a firewall? Proxy server? anything that might manipulate the request?
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

uscostAuthor Commented:
well, there's the watchguard firewall, but I don't expect that to play a factor since no address or dns changes have been made....

I could be wrong.
0
netcmhCommented:
I would check the rules on that firewall, just to rule it out.

Please also check the hosts file on your computer. I understand that the name and IP has not changed.
0
Radhakrishnan RSenior Technical LeadCommented:
Hi,

As you mentioned that you alreay have A record, is this pointing to the internal server or external ip?

First find out what the IP address is of the external web server if you do not already know it. Go to Start > Control Panel > Administrative Tools > DNS and locate example.com. Right-click and choose “New Host (A or AAAA)”. Type “www” into the name field, and the IP address of your external web server into the IP Address field. Click the “Add Host” button to save.
0
uscostAuthor Commented:
the host file just shows default localhost

. The A record has www.test.com and shows the correct ip address of the external web server.

Checking the firewall now.
0
uscostAuthor Commented:
Check the firewall when I try to go to test.com, no traffic was block or redirected.
0
netcmhCommented:
Can you put your PC before the firewall and try again? You said that from the outside the domain resolves just fine. I would like you to rule out the possibility of your network/domain causing you to not resolve from the inside.
0
uscostAuthor Commented:
ok, you were right. I setup a laptop with a public address to the outside bypassing the firewall and it work fine...

if that's the case, dns issues internally or firewall? but nothing was change... is there a cache i'm missing?
0
netcmhCommented:
It could be. I would re-examine the firewall or any other devices like a proxy server. recheck DNS. I know it's a pain, but this test proves that it's not wordpress. It's something on our network that's not allowing it through to the right destination.
0
uscostAuthor Commented:
its got to be a cache, i type in the ip address of the website, and it shows the old website.....
0
netcmhCommented:
You got it. Clear arp. clear cache on your browser :)
0
uscostAuthor Commented:
unfortunately, that did not work.

any other ideas? this is happening more than one computer, not just mine.
0
netcmhCommented:
Do you have a caching proxy server or firewall in between you and the world? If so, try flushing it.
0
uscostAuthor Commented:
i don't have any proxy server. Clear arp table on firewall already.

Flush dns on computer, clear dns cache on dns servers. Restart all dns services as well.

On my computer, i just put in an external dns and it was able to pull up the page fine. At this point, I'm thinking its a dns issue, I will try to reboot servers tonight.
0
netcmhCommented:
If what you said is right, then yes, the DNS server was caching the entry. Using free external DNS servers would help.
0
uscostAuthor Commented:
yeah, the only strange thing is I check my dns forwarders and those dns are set in there...it didn't work, but on the local computer if i set those dns as main dns server, it works fine.

I'm just going to reboot the server tonight and see what happen.
0
uscostAuthor Commented:
Reboot did not help.

Anyone have any other ideas?
0
netcmhCommented:
what did you reboot? You've tried rebooting the computer. Did you reboot your firewall? And, any other network appliance that could be hampering you from reaching the intended destination?
0
uscostAuthor Commented:
yes, I rebooted all devices.
0
netcmhCommented:
If you've taken care of stuff on your end, could your ISP be doing something funny?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
uscostAuthor Commented:
what I have notice is that when I type in the url externally, www.test.com, it keeps reverting to test.com.
I spoke to the hosting company and they said its a wordpress thing....it wasn't doing this before so not sure if its related.
0
niermissCommented:
@uscost - did you ever find a solution? I'm in the same predicament. Thanks.
0
netcmhCommented:
Check your external DNS records. Check your WP settings.
0
uscostAuthor Commented:
hey niermiss,

it was a wordpress dns issue on the backend of the hosting provider.
I didn't have the settings for it, the hosting people had to change it.
0
netcmhCommented:
Thanks for the grade. Good luck.
0
niermissCommented:
FYI, our web host was no help. We had our developer change the WordPress Address (URL) and Site Address (URL) so www was the primary...that did the trick!
0
uscostAuthor Commented:
yeah that was it. our newbie developer screw it up by doing something like that, but forgot to change something, so we had two wordpress website pointing to same domain.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.