exchange 2007 relay is not hitting the proper receive connector

I am setting up a receive connector on an exchange 2007 box to relay from the outside to internal and outside users.   Internal users seem to be working, but can't send email to external addresses.   I did add in the PS command for"Ms-Exch-SMTP-Accept-Any-Recipient".  The issue seems to be that the mail is hitting the default receive connector and not the one that I specifically setup for the remote IP.   I did this by setting up the protocol logging on this connector.   I see the connection in the log if I enable the logging on the default connector, but never see it when setup on the new connector.  

I have verified the remote IP and even tested it with another remote IP and can't seem to get it to go to the new connector.

As far as receive connector precedence, I thought as long as you had a specific IP in the "receive mail from remote servers..." that would take precedence over the default.


Thanks.
tiptechsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
You create relay connectors for application servers. For user related emails exchange uses the default connector. Also your requirement is not clear, what you are trying to achieve here.
0
tiptechsAuthor Commented:
We have an outside company that is going to be relaying email off our server.  The emails will be going to internal users and some emails will be going to remote addresses.  The internal emails go through, we just have the issue when the relay is to an external address.

Thanks.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

tiptechsAuthor Commented:
No, that is not the setup.     The emails are being generated on a remote server (3rd party) and are relayed through our mail server to internal addresses and external addresses.

When testing with the "telnet server 25", I get unable to relay soon as I type in a recipient that is not in the domain.   I believe this is due to it not hitting the correct recieve connector.

Thanks.
0
AmitIT ArchitectCommented:
Okay in that case you need to follow different method. First you need to create a DNS record, configure that DNS record in your connector. Then configure the same dns record in your 3rd party tool.
0
AmitIT ArchitectCommented:
0
Jamie McKillopIT ManagerCommented:
Hello,

On your receive connector, go to the permissions tab. Make sure "Anonymous Users" is the only box selected. Now run:

Get-ReceiveConnector "<Connector Name>" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

JJ
0
tiptechsAuthor Commented:
jjmck,  I did try that with no luck.    Do you know if there is a way to view the "extended rights" of a recieve connector from the power shell just to make sure it took the command, etc..?
0
tiptechsAuthor Commented:
amitkulshrestha, I haven't tried the dns change yet.  But can you tell me why just adding the dns record / fqdn would fix this?  

On the current received connectors they are all setup with the same FQDN (server.localdomain.com).

Thanks
0
AmitIT ArchitectCommented:
Think logically if your 3rd party server is not configured to use this connector, how it will relay email to connector. It will use the default one. So, you need to tell 3rd party server to use this connector by using DNS.
0
Jamie McKillopIT ManagerCommented:
You do not need a new FQDN/DNS record. You would only need that if you setup the connector on a different IP. The connector will be chosen if the IP of the sending server matches the IP specified on the connector's allow list. When you setup the connector, did you select a type of "Custom"?

I would delete the connector and start again. Here are the instructions on how to create it. There are two options you can use to set the permissions.

http://blogs.technet.com/b/exchange/archive/2006/12/28/3397620.aspx

JJ
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tiptechsAuthor Commented:
The 3rd party is using the IP of the mail server to send to the mail server.

I recreated the connector as you stated and it now appears to be working.   I didn't originally create the connector so not sure if the custom option was used.

Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.