RDS and AD DS on Windows 2012 - Errors

I have an environment in which I'm replacing the main server (2003 R2) with a 2012 Standard.  This new server needs is to be a domain controller, as well as host an application accessible via RD.  Bought all the terminal sessions licenses, etc.
Installed AD and promoted new server.
Terminal services running fine, but when trying to install the 'broker', I kept receiving errors.  
I found a work around on a forum that said you have to demote the server, then install RDS, then reinstall AD and promote.
This worked, but now still having errors.
I found a support article from Microsoft saying "Remote Desktop Services role cannot co-exist with AD DS role on Windows Server 2012."

Is this still the case?  Is there a patch yet?  Are we not to be able to have a DC and have it be a terminal server?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
It's not supported in RTM.


However, see improvement 2 with this update.

pcturnkeyAuthor Commented:
Thanks.  Those were the articles I was referring to.  I applied the patch, but still am getting errors.
pcturnkeyAuthor Commented:
I followed the suggestion to install RD Session host role without using the RD Connection Broker found at this link:


However, I went through the article provided and followed the instructions, but it is still giving me errors.

Let me first say that I had followed a technet post that suggested to remove to demote server, remove AD DS, install RD Connections broker, reinstall AD DS, and re-promote the server to get it to work.  I had tried this, but still didn't work (though it DID install the broker).

Before trying your suggestion, I removed the broker service and the the other features that came with it.  Now I just have RD Licensing and RD Session host installed, along with the RD Cals.  Server is also activated.

Now I have these issues:

First, still cannot create RDP connection from outside or inside router (router port forwarding is adjusted).

Also, RD Licensing Diagnoser says:  1) Number of licenses available for clients: 0  2) "License server licserver is not available.  This could be caused by network connectivity problems, the Remote Desktop Licensing service is stopped on the license server, or RD Licensing is no longer installed on the computer."  

Other errors:  In Remote Desktop Services > Servers > Events:  Error ID 85 Microsoft Windows TerminalServices Licensing - "The Remote Desktop license server could not be registered as a service connection point in AD DS.  Ensure that there is network connectivitiy between the license server and AD DS.  To register the license server as a service connection point in AD DS, use Review Configuration in the RD Licensing Manager Tool."

In the Configuration, all the marks are green 'checks' and says "This license server and the Network Service account are members of the Terminal Server License Servers group in AD DS.  This license server will be able to issue RDS Per User CALs to users in the domain, and you will be able to track or report the usage of RDS Per User Cals on the license server."

"This license server is registered as a service connection point (SCP) in Active Directory Domain Services.  The license server will appear in the list of known license servers in the RD Session Host Server Configuration tool."

Any idea what is going on?
pcturnkeyAuthor Commented:
I had to work with Microsoft on this one.  The order of operations is important- run the patch, install AD services, then RDS.  Even then, they couldn't resolve some of the licensing errors.  Since everything appeared to be working, just without displaying correctly, Microsoft wanted to leave it be unless something goes wrong- at which point they want me to call them back...

Here were some of the resolutions to the above issue:

-There are two spots you need to adjust for the listening ports for RDP in the registry.  I had only adjusted one.

-Although all the same exemptions and forwarding were made in the router as in the past, the router didn't like this new 2012 Server- specifically the firewall setting in the router.  Once disabled, it allowed the rest of the packets through.

-Windows firewall was adjusted, as well.  We had all the RDP ports and programs allowed, but had to open Com+.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pcturnkeyAuthor Commented:
The solution was to work directly with Microsoft.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.