• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1253
  • Last Modified:

IBM TDP Exchange Backup Service Account Permissions

This issue is going to be hard to explain.  

My Environment:
Windows Server 2008 R2 Enterprise
Exchange Server 2010 SP2
Backup Solution: IBM Tivoli Data Protection (TDP) for Exchange v6.1.2

Problem:  The backup runs on a scheduled task under the domain administrator service account.  It works flawlessly with that setup.  I want to change the task to run under a new service account.  The scheduled task is set to call a batch file that launches the TDP Exchange CLI along with a set config and log files to control the backup set.
(attached image)  In the scheduled task it simply shows that it hasn't completed.  Investigating a little more I ran the a command prompt as the service account and called the backup command to launch to TDP Exchange CLI and get  "Access is denied".   I've setup the service account with the same permissions as the domain admin and double checked that the account has admin permissions on the server.  However I still get the "Access denied" message at the command prompt? I'm not seeing anything related to this in event viewer.
  • 3
  • 2
1 Solution
AmitIT ArchitectCommented:
You need to add this account under exchange view only administrator group in AD as well. Then it will work.
ats2012Author Commented:
Not sure what you mean by "exchange view only admin group" but I've already copied the permissions from Administrator to the service account including security groups:
Enterprise Admins
Exchange Domain Servers
Exchange Servers
Exchange Services
Organizational Management
Schema Admins

Some of the Exchange specific security groups that aren't associated are:
Exchange Windows Permissions
Exchange All Hosted Organizations
Server Management
AmitIT ArchitectCommented:
Org Management is enough. You have required permission. Did you tried with GUI interface.
ats2012Author Commented:
Yes, I can launch the GUI as the service account.

I'm logged into the server with my account (domain admin) and I'm doing a 'run as' for the service account.  I get a UAC popup verifiying whether I want to run it, but that wouldn't be blocking anything would it?
ats2012Author Commented:
The backups started working under the service account.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now