WCF Service - connecting by net.tcp

I receive the following calling my WCF Service using the net.tcp protocol on IIS7(WAS)

[The message could not be dispatched because the service at the endpoint address 'net.tcp://localhost:9090/AppointmentServiceIISHost/AppointmentServiceIISHost.svc' is unavailable for the protocol of the address.

I enabled the protocol on the website and the application. I enable Non-HTTP activation.
web.config
Lawrence AverySystem DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

käµfm³d 👽Commented:
Did you enable net.tcp on the site (not your application, but the whole site)?
0
Lawrence AverySystem DeveloperAuthor Commented:
Yes enabled protocol ( http,net.tcp)  on the Default Website. I also edited permission of application by giving permissions to the IIS_IUSR and Network Service accounts.

I received the same message below:

The message could not be dispatched because the service at the endpoint address 'net.tcp://localhost:9090/AppointmentServiceIISHost/AppointmentServiceIISHost.svc' is unavailable for the protocol of the address.
0
Lawrence AverySystem DeveloperAuthor Commented:
I think I got further; I am receiving this message now:

There was no endpoint listening at net.tcp://localhost:9090/AppointmentServiceHostIISHost/AppointmentServiceIISHost.svc that could accept the message. This is often caused by an incorrect address or SOAP action.
0
Lawrence AverySystem DeveloperAuthor Commented:
Resolved by setting permissions on my WCF Service directory to group IIS_IUSRS  and also changing my SqlConnection to using a User ID and Password that was in the Database as a user and login.  Otherwise it was trying to log into the Sql Server using the IIS_USRS group id.

Because  my WCF Service directory did not have the IIS_IUSRS in its security properties that caused  a lot of grief.  I did not place this under c:\inetpub\wwwroot because my instructions from a document that I received a year ago from an instructor did not indicate this can be issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lawrence AverySystem DeveloperAuthor Commented:
See above comment.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Development

From novice to tech pro — start learning today.