Troubleshoot partial failed import

I have a FM table that shadows an ODBC Oracle sandbox table in an enterprise data warehouse (fmoracle.fmp12). I normally create 100-200 records in another local FM table (fmlocal.fmp12) that I upload biweekly (export subset of fmlocal and import to fmoracle). There are 14 fields of type text, number and date in fmlocal.fmp12. I had some data corruption in the fmoracle.fmp12 table, so I deleted and recreated it. When I tried to upload the fmlocal data to fmoracle, 1050 of the records uploaded, but 98 failed. I exported the 98 into another temp file and tried again without success. I also exported to xls, xlsx, xml, and fmp12 and tried to import each of those files into fmoracle, but none of the 98 succeeded. I tried inserting the xlsx file via SQL uploader to the same fmoracle table without success.

The data fields look like they are formatted correctly, but this process I regularly use is failing. What should I troubleshoot?

Mark
MarkJulieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DavidSenior Oracle Database AdministratorCommented:
I recommend you check your output log(s) for errors or messages and perhaps share what you find.  My hunch is that you are somehow violating a unique key constraint.

Knowing the description of the table(s) would help us as well.

dvz
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MikeOM_DBACommented:
Unless you want for some reason to keep the error(s) reported in the logs secret, you should share them with us.
0
MarkJulieAuthor Commented:
Can someone point me to the default location for the import log? Spotlight is not finding it by that name, and Google hasn't helped.
0
DavidSenior Oracle Database AdministratorCommented:
Just for fun, are you running imp (old) or dpimp (current)?

Both executables allow the log file name to be passed on the command line, or in the parameter file.  The command should also specify the DIRECTORY, a mount point previously defined to Oracle with RW permissions as appropriate.  So, your log should be in the DIRECTORY+logname.  

See for specific syntax: http://docs.oracle.com/cd/E11882_01/server.112/e22490/dp_import.htm
0
MarkJulieAuthor Commented:
The Oracle documentation and advice from dvz was good but way over my head since I am not a dba. Hence I have not found the import log. Our enterprise dba advised me to remove primary keys from the Oracle table and reupload. This allowed me to upload the 1049 records. After uploading, I ran a SQL query for duplicates and detected one duplicate ACCT_NO in the Oracle table which does not show up in the parent FMPA table from which I exported when I query it for duplicates. After more nonspecific troubleshooting, I eliminated the error without discovering the cause.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
FileMaker Pro

From novice to tech pro — start learning today.