• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 302
  • Last Modified:

CentOS Installation


I have followed the steps above to install for a Cent OS 6.4
All seems to be working except that my test page is not loading. Is there a firewall issue?
2 Solutions
sivagnanam chandrakanthTechnical LeadCommented:
Have you added virtual host in apache for your application/folder..
Starquest321Author Commented:
how do I do that? A little new at it
sivagnanam chandrakanthTechnical LeadCommented:
go to /etc/httpd/conf/httpd.conf  and add below lines

<VirtualHost *:80>
    ServerAdmin ***@***.com
    DocumentRoot /var/www/html  /*your folder directory*/
    ServerName localhost /*or any url like demoapp.com*/
    ErrorLog /var/log/httpd/test.error_log
<Directory "/var/www/html/"> /*your folder directory*/
       AllowOverRide All
       Options +Indexes
       Order allow,deny
       Allow from all

Remove my comments with /*........*/
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Starquest321Author Commented:
I have updated the file as per your suggestion - but still no change. .
Gerwin Jansen, EE MVETopic Advisor Commented:
What error do you get and from where are you trying to load the test page? From the CentOS server or from an other location?

#ls -lZ /var/www/html


#cd /var/www/html
#restorecon -R index.html <whatever is the document you used as index page>

Its SE-Linux mode which is not executing the file with different context

#ls -lZ /var/www/html
sivagnanam chandrakanthTechnical LeadCommented:
Make sure you did the following

1) Restart Apache after making the changes (/etc/init.d/httpd restart)
2) make sure the file you are hitting is placed under /var/www/html
3) if you are hitting the server from other machine...put a host entry with ip and domain name


For Linux : edit /etc/hosts file and add below line

192.**.**.**(Your ip) test.nadian-investments.com

For windows edit C://windows/system32/drivers/etc/hosts file and add

192.**.**.**(Your ip) test.nadian-investments.com

This is added if your domain is invalid..

Also check /var/log/httpd/test.error_log for more details
Seth SimmonsSr. Systems AdministratorCommented:
is selinux enabled (what happens when you do getenforce ?)

i typically disable selinux (change from enforced to disabled in /etc/selinux/config) for permanent change (requires reboot) or setenforce 0 for current session; i've had this problem before

if you need to keep selinux then modify it to allow apache


virtual hosts are if you are hosting multiple websites

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now