• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 237
  • Last Modified:

Problem with old program and database

We have an old program that is called fmr.exe and it should open a database that is saved in access 2.0 (mdb file) and the error message "Fatal error: cannot open 'strings.mdb' appears.

Could it have something to do with missing files in windows?
1 Solution
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
These are just shots in the dark:

Did this just occur suddenly? Or were there environment changes that caused this (like upgrading to a new OS, for example).

Can you locate the strings.mdb file? If so make a copy, and then try to open that copy with Access 2003 or earlier (2007 and up would try to convert it, which won't do you any good at this point).

Is the fmr.exe file running on a different machine? If so, you might try copying strings.mdb from there and putting it on the trouble machine. Same with strings.mdb
I agree with above...the most important thing is location strings.mdb

Do you perform frequent backups on this file?
You might need to think about replacing fmr.exe with something newer.  If you are still in contact with the creator you might be able to get it upgraded to use a newer version of Jet/ACE.  If not, you'll probably need to rewrite it.

If you have A2.0 loaded, try to compact and repair the .mdb.

If you did any add/remove program work, the mdac version you need may have gotten replaced and you'll have to reinstall it.

When you rely on software this old, you eventually need to isolate it on a PC that is never upgraded to avoid loosing/replacing the support files the app needs.
MickeCAuthor Commented:
Hi! The program fmr.exe and the db file strings.mdb are not in an ordinary computer it is placed in a small special computer on a big Printing press that we bought on an auction, we just want to put the program on an ordinary PC just in case something bad happens to the machine. So we got the files from 1.44 floppydisk that came with the press and installed it on an W98 PC and that worked, but it is when the program are going to load the string.db the error occurs. I will try to compact and repair it tomorrow, if i manage to load the db in access 2007.
If it was written with A2.0, you won't be able to open it with A2007.  You might be able to open it with A2003 but if I remember correctly, you'll need to download an add-in.  You are better off with A97 but even that might still need the add-in to read the old file.  This was long before MS made a concerted effort to have newer versions of Access retain the ability to read old file formats.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now