Use guest network on wireless router WITHOUT enabling DHCP (using SBS 2008)?

A small business client was using an older Netgear wireless router that had a guest network feature (don't recall the model). It worked fine even though DHCP was turned off on the router (SBS 2008 Server was handling DHCP).

The Netgear died and I replaced it with the Cisco e4200. Unfortunately, it looks as though the e4200 guest network, as far as I can find out, will not work without the e4200 handing DHCP. The guest client seems to connect but does not get an IP address and cannot access the internet.

I guess I have 3 questions:

1. Has anyone been able to successfully get the guest network on the e4200 to work without DHCP enabled?

2. Has anyone found a decent wireless router for a small business without a big budget that has a working guest network without requiring DHCP to be handled by the router itself?

3. Does anyone have a suggestion for a good "workaround" that does not include having another separate, dedicated internet connection?

Regarding number 3, I've seen some postings about "creative" ways to use a wireless access point, different subnets, etc.

My goal is to be able to offer wireless connections for guests to get on the internet without them having access to my client's physical network. Ideally, I'd want the internal network to be completely hidden from view, but  I guess if they could "see", but not have access to internal network, that might be acceptable.
Sal SoricePresidentAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ugo MenaCommented:
1. The guest network feature in the e4200 will not work without internal DHCP server enabled.

2. The guest network of almost any router will not work without a DHCP server to handle the LAN addressing.

3. A good workaround without using a second dedicated Internet connection would be to "Cascade the Linksys router to your main LAN router (LAN-WAN)".

 LAN to WAN – Connecting one of the Ethernet ports (LAN ports) of the main router to the Internet port (WAN port) of the secondary router.

This type of cascading requires the main router and the e4200 router to have different IP addresses.  This connection makes it easier to identify which router the computers and other devices in the network are connected to since they will have different LAN IP segments.

AND computers that are connected to the main router will not be able to communicate with the secondary router, and vice versa since there are two (2) different networks.


However, for it to work in this manner the DHCP server will need to be enabled on the e4200. It is also not using the Guest network feature, since ALL wireless clients will be connected to the Internet through another subnet.

Here is Cisco/Linksys KB article on how to get this setup:

http://kb.linksys.com/Linksys/ukp.aspx?pid=80&vw=1&articleid=3733
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sal SoricePresidentAuthor Commented:
ultralites: Thanks for the good info! Will try the cascading option - looks like that will work best.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.