Open Office 2.4 Configuration Change for OpenOffice 4.0

Hello,

I have an application that uses OpenOffice 2.4 currently for a specific function to work. In order for the application to use OpenOffice, the following changes are required in the Setup.xcu file:
CHANGE FROM:
<prop oor:name="ooSetupInstCompleted">
  <value>false</value>
</prop>
<prop oor:name="ooSetupShowIntro">
  <value>true</value>
</prop>

CHANGE TO:
<prop oor:name="ooSetupInstCompleted" oor:type="xs:boolean">
 <value>true</value>
</prop>
<prop oor:name="LicenseAcceptDate" oor:type="xs:string">
 <value>2013-04-01T14:00:00</value>
</prop>
<prop oor:name="FirstStartWizardCompleted" oor:type="xs:boolean">
 <value>true</value>
</prop>

How do I make this change in Open Office 4.0?


Thank you,

Ashley
LVL 1
AshleySPMAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ltlbearand3Commented:
Ashley,

It appears that you just need to disable the First Start Wizard, is this correct?  Many setup features have changed in OOo 4.  I have been playing around with this for a little bit and  you need to make an modification to the registrymodifications.xcu file in the appdata folder for the user.  You need to add this node:
<item oor:path="/org.openoffice.Setup/Office"><prop oor:name="FirstStartWizardCompleted" oor:op="fuse"><value>true</value></prop></item>

Open in new window

In front of this node:
<item oor:path="/org.openoffice.Setup/Office"><prop oor:name="ooSetupInstCompleted" oor:op="fuse"><value>true</value></prop></item>

Open in new window

Give that a try and let me know how it works.

-Bear
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AshleySPMAuthor Commented:
Yes, I need to disable the first start wizard. Thanks so much. Open Office is accessed by the system account withinin the application. Is there a way for me to make this change under the system account?


Thanks!
0
ltlbearand3Commented:
We should be able to make that work.  Just update the registrymodifications.xcu file in the system account app data folder - should be very similar to the location where you made the change to setup.xcu.  If that does not work, post the path where the setup.xcu file resided and I maybe can take a look (Just remove any confidential information in the path).  What OS is this on?
0
AshleySPMAuthor Commented:
That worked :-) Thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.