SOLARIS vi arrows -> insert and normal mode

Hi,

Can somebody please provide me a solution to use Solaris vi by using the arrow keys?
I've tried all Google options such as:

~/.exrc:
set t_ku=[control-v][up-arrow]
set t_kd=[control-v][down-arrow]
set t_kr=[control-v][right-arrow]
set t_kl=[control-v][left-arrow]

And it's not working.

I'd like to use normal arrows into both insert/normal mode.

HUGE Thanks
LVL 1
g0allAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joseph GanSystem AdminCommented:
what is the output of this command:
echo $TERM
0
DavidPresidentCommented:
This is not so much a solaris problem as a standard UNIX thing. You have to tell the O/S what terminal emulator you are using.   If you were using putty, for example, then you need to not only tell putty what terminal you want to emulate, but you need to tell the O/S.

I'll play the odds, and say that you should try entering
TERM=xterm; export TERM
then try vi
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joseph GanSystem AdminCommented:
Thats why I want to find out the current terminal setting first...
0
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

g0allAuthor Commented:
Partially solved.

I've had ddterm.

In normal mode arrows are working. In insert mode, when pressing arrows letters are inserted.
0
DavidPresidentCommented:
That is how it is supposed to work. When in insert mode do NOT use the arrows.  Insert mode must be off to use arrows.
0
MikeOM_DBACommented:
This will allow to use vi commands on the command line:
export TERM=xterm
set -o vi

Open in new window

0
Joseph GanSystem AdminCommented:
You can use "TERM=vt100; export TERM"
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.