ASA - 3750 Trunk not able to ping gateway

I have the following configs on the ASA and 3750 switch: The issue is that I added the vlan
1533 (i.e switchport trunk allowed vlan add 1533) to the trunkport and cant ping the ip
address of the ASA for that vlan (i.e. ping 172.15.33.1). I have icmp enabled on the firewall and can also ping the 172.16.33.1 address. What am i overlooking to allow me to ping the
ASA gateway address from the switch. I tried an extended ping as well but unsuccessful.


Cisco ASA 5510 CONFIG

interface e0/1
decription Trunks to Inside Network
no nameif
no security level
no ip address
!
interface e0/1.1533
vlan 1533
ip address 172.15.33.1 255.255.255.0
nameif Tester-Valn
security-level 100
!
interface e0/1.1633
vlan 1633
ip address 172.16.33.1 255.255.255.0
nameif Development Vlan
security-level 100

!!!!!!Other vlans omitted for simplicity!!!!!


SWITCH CONFIG

interface GigabitEthernet1/0/47
 description Trunk to Firewall Port E0/1 INSIDE
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1, 200-210,1533,1633
 switchport mode trunk
!
interface vlan 1533
 ip address 172.15.33.3 255.255.255.0
 no ip route-cache cef
 no ip route-cache
!
interface vlan 1633
 ip address 172.16.33.3 255.255.255.0
 no ip route-cache cef
 no ip route-cache
solarisjunkieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BigPapaGottiCommented:
What is the output of the command "show interface GigabitEthernet1/0/47" Are both interfaces up/up?
0
gcl_hkCommented:
Do you have create the VLAN1533 on 3750 vlan db?

Also, provide the output for the following command to check the trunk status with ASA:

show int g1/0/47 trunk
0
AkinsdNetwork AdministratorCommented:
If your switch has the proper gateway, then 1 possibility is eliminated.

It looks though that you may have route issues. Just so you know, routes may exist in your configuration in the Asa that may not show in the table when you show route


1st, let's trace the path from the switch to see where it is going
traceroute 172.15.33.1


Also on the switch, do
show route
Show ip protocols

If no routing protocols exist, make sure to turn "ip routing" on and configure static route

On the firewall
Show route
Show run route

Do these above for now and we'll go from there
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Redefine Your Security with AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Check out our on-demand webinar to learn more about how AI can help your organization!

rauenpcCommented:
My guess would go with gcl_hk as I have many times in the past defined a layer 3 vlan interface but forgot to define the layer 2 portion.
As far as routing goes, this should not be a concern (at least within the bound of a test ping between switch and directly connected ASA). Both devices have a local interface with the same subnet defined, and a ping between them doesn't require any actual routing. It is simply an ARP to get an IP to MAC mapping, and then from there it's direct l2/l3 communication over a direct link. As long as both the l3 interfaces are up and the l1/l2 portion is running properly you will be able to ping. This assumes that you are pinging to/from the vlan 1533 interface, and not specifying different source interface when performing the ping test.
Going beyond the ping may very well require some routing to be configured.
0
AkinsdNetwork AdministratorCommented:
Ping works when he pings the 16 network meaning the switch most likely has a default route set to 16.?

Wait for the output I requested for first rather than jumping the gun
0
solarisjunkieAuthor Commented:
Thanks all and the issue was the connection to the firewall was actually through another switch. I added the vlans to that switch and the pings went through fine.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.