Exchange 2007 not receiving email

I have an SBS 2008 server which runs Exchange 2007 SP3 UPdate Rollup 11.
Today I changed the subnet from 192.168.1.x to 192.168.202.x
I had to manually change 1 DNS entry and aslo the IP address for the exchange send and receive connectors.

I cannot receive email. Sending works fine but the receive fails.
I have event ID's 1017 and 1019.
The Fix my Network Wizard says "Exchange SMTP Connector is Invalid"
If I telnet to my mailserver on port 25, I get this: 421 4.3.2 Service not available, closing transmission channel
How do I find and correct this error?
LVL 1
LostInWindowsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Did you let the fix my network wizard do its thing?
You should really have changed the IP address using SBS, rather than manually. I would suggest that you run the connect to the internet wizard again, enter the new IP address and let SBS do its thing. There are a lot of settings "under the hood" that SBS will apply.

Simon.
0
LostInWindowsAuthor Commented:
Yes, I followed the instuctions found in this link. http://social.technet.microsoft.com/Forums/en-US/55be2c21-5267-4bd2-bc88-9f23b1365e74/sbs-2011-changing-subnets 

It worked on everything properly except 1 DNS entry and the receive connector. After that , I restarted the router, the server and each Workstation. The Fix my network wizard still tells me that the connector is invalid.

I have the results for get-receiveconnector|fl if you want me to post them, just ask.
0
Simon Butler (Sembee)ConsultantCommented:
You need to look at the remote IP subnets on the Receive Connectors. SBS does things a little differently - it creates a third connector for accepting email from the internet - that is probably the one you need to check. If you modified the Default then that doesn't have anonymous enabled by default, so will not work correctly.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LostInWindowsAuthor Commented:
Thanks, that was a bigger headache than I wanted for a Monday.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.