Create port channeling for connectivity to VNX Storage system

How do I create a port-channel on my cisco switch for my new VNX Storage?  I am trying to create a new CIFS on my network.   When I configure the same port-channel 20 and the same configuration that is on the CS-120 to an unuse interface gig1/29, my existing network CIFS share got disconnected when plug into the VNX storage.  Do I create a new Port-channel?  What are the steps I need to take?

Currently configuration on my Switch that is connected to EMC CS-120, this port is for CIFS:

interface Port-channel20
 switchport
 switchport access vlan 101
 switchport mode access
!
interface Port-channel21
 switchport
 switchport access vlan 101
 switchport mode access

interface GigabitEthernet1/31
 description TO 2FDC4948 G1/31 EMC CS-120 CGE1
 switchport access vlan 101
 switchport mode access
 channel-group 20 mode on
 spanning-tree portfast
!
interface GigabitEthernet1/32
 description TO 2FDC4948 G1/32 EMC CS-120 CGE0
 switchport access vlan 101
 switchport mode access
 channel-group 20 mode on
 spanning-tree portfast
!
interface GigabitEthernet1/33
 description TO 2FDC4948 G1/33 EMC CS-120 CGE1
 switchport access vlan 101
 switchport mode access
 channel-group 21 mode on
 spanning-tree portfast
!
interface GigabitEthernet1/34
 description TO 2FDC4948 G1/34 EMC CS-120 CGE0
 switchport access vlan 101
 switchport mode access
 channel-group 21 mode on
 spanning-tree portfast


New Configuration to connect to my EMC VNX  (When I plug the VNX cable in, current share drop)

interface GigabitEthernet1/29
 description TO 2FDC4948 G1/31 EMC VNX-5300 CGE1
 switchport access vlan 101
 switchport mode access
 channel-group 20 mode on
 spanning-tree portfast

Please Advice.
c7oiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AkinsdNetwork AdministratorCommented:
Yes you need separate ether channel for the connection

Do a "show etherchannel" to see which ports are bundled together in one view

Eg from your config, 1/29 and 1/32 belong to Po20

You need to bundle unused ports together to create a new port channell

Interface range gi1/40 - 41
Channel-group 22 mode on

This will bundle port 40 and 41 together to create Po22

All the best
0
c7oiAuthor Commented:
Do I have to create a channel-group 22 first?

What is the command for this?
0
c7oiAuthor Commented:
I want to confirm if this is the command I should use to configure my new port.

To Add a Port Channel
switch# configure terminal  
switch (config)# interface port-channel 22
switch (config)#switchport
switch (config)#switchport access vlan 101
switch (config)#switchport mode access
switch (config)#exit

To bundle the port:
switch# configure terminal  
switch (config)# interface range g1/40-41  
switch(config-if)# sswitchport access vlan 101  
switch(config-if)# switchport mode access  
switch(config-if)#channel-group 22 mode on
switch(config-if)#panning-tree portfast


You guys are the BEST.
0
AkinsdNetwork AdministratorCommented:
Bundling is what adds the port channel. After bundling or adding, you the configure

To bundle/add the port:
switch# configure terminal  
switch (config)# interface range g1/40-41  
switch(config-if)# switchport access vlan 101  
switch(config-if)# switchport mode access  
switch(config-if)#channel-group 22 mode on
switch(config-if)#panning-tree portfast
0
AkinsdNetwork AdministratorCommented:
Bundling is what adds the port channel. After bundling or adding, you the configure

To bundle/add the port:
switch# configure terminal  
switch (config)# interface range g1/40-41  
switch(config-if)# sswitchport access vlan 101  
switch(config-if)# switchport mode access  
switch(config-if)#channel-group 22 mode on
switch(config-if)#panning-tree portfast


The following may actually not be needed since you already did that in one shot above.
It won't harm anything though.

Verify by issuing show int port-channel 22 switchport

switch# configure terminal  
switch (config)# interface port-channel 22
switch (config)#switchport
switch (config)#switchport mode access
switch (config)#switchport access vlan 101

switch (config)#exit
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.