windows picture and fax viewer opening pdf's

I  have a workstation that keeps using Windows Picture and Fax viewer to open a pdf.  Of course, I can't view anything.  I've tried changing the default program to use with the pdf file type, but it doesn't change anything.  I've also tried uninstalling and reinstalling adobe reader.  But that didn't fix it either.

Any ideas?
MalamamotoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GaryCommented:
I assume you click the Always use the selected...
0
MalamamotoAuthor Commented:
Yes, I clicked that and I checked the folder options in the control panel.  They all look fine.  But picture/fax keeps trying to open the file.
0
MalamamotoAuthor Commented:
Not sure if this makes a difference, but I am trying to open the pdf from IE.  I'm trying to avoid having to save the file first before I open it.  I just noticed that if I save the file and then open it, adobe reader opens it by default.  But if it's a link to a pdf in IE, the windows photo/fax viewer opens it.
0
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Joe Winograd, Fellow&MVEDeveloperCommented:
> I've tried changing the default program to use with the pdf file type, but it doesn't change anything.

How did you try to do this? Did you try right-click in Windows Explorer (or whatever file manager you use) and then [Open with]>[Choose default program]?
0
MalamamotoAuthor Commented:
yes, right click file, open with, select from list, select adobe reader, check use as default, then save.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Our emails just crossed. Now that I know it's in IE, here's how to fix it:

Control Panel
Programs and Features
Adobe Reader (will likely have a version number, such as 9.5)
Change
Repair

That should do it. Regards, Joe
0
MalamamotoAuthor Commented:
I've actually done a full uninstall/reinstall with no success.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
IE doesn't use the same Open With program...that's why Adobe Reader is opening it when you save the file but not when you're in IE. The above steps should fix it for IE.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
I've had uninstall/reinstall not work while Repair does work. Try it...can't hurt. If that doesn't fix it, we'll try something else.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Btw, do you want the PDFs to open in IE or in Adobe Reader?
0
MalamamotoAuthor Commented:
It's repairing as we speak.

I'd like it to open in adobe reader.  but I'll take either one at this point.
0
MalamamotoAuthor Commented:
Repair didn't change anything.  :(
0
Joe Winograd, Fellow&MVEDeveloperCommented:
What versions of IE, Windows, Adobe Reader?
0
Joe Winograd, Fellow&MVEDeveloperCommented:
I'm not saying this is the permanent solution, but as a troubleshooting step, try a different PDF reader, such as the excellent (free) Foxit Reader:
http://www.foxitsoftware.com/downloads/

It's been a while since I installed it, but as I recollect it will give you the option of making it the default PDF reader. What happens when Foxit is the default?

Also, still would like to know the various versions/editions of all the relevant software. Regards, Joe
0
GaryCommented:
How are you trying to open the pdf from IE?
From a link in a webpage?
0
jcimarronCommented:
Malamamoto --
Try Control Panel|Default Programs|"Associate a file type or protocol with a specific program".  After the list has populated, scroll to .pdf.  Is it associated with Adobe Reader?  If not change it to Adobe Reader.
0
MalamamotoAuthor Commented:
I figured out, it's not an IE problem.  It's a QuickBooks Pro 2012 problem/Windows User Permissions problem.  I thought it was IE related because it was happening in a remote session in IE.

I logged in as an admin user and the problem went away.  I log in as a regular user and the problem returns.  Any ideas now?
0
jcimarronCommented:
Malamamoto--
You seem to have fixed the problem, so I do not know what you are asking now.

To be sure .pdf files are associated with Adobe Reader go to Control Panel|Default Programs|"Associate a file type or protocol with a specific program" and see if .pdf is indeed associated with Reader.
0
MalamamotoAuthor Commented:
No because admin's can't establish remote sessions.  And it's against company policy to give a regular user admin permissions.

So the solution we're looking for is to be able to open a pdf within QuickBooks, with normal user permissions.

And yes, pdf files are associated with adobe reader.
0
jcimarronCommented:
Malamamoto--
"So the solution we're looking for is to be able to open a pdf within QuickBooks, with normal user permissions."
Ah.
0
MalamamotoAuthor Commented:
Yup.  Wouldn't you agree that a good solution wouldn't include simply giving a user admin permissions.  That would be pretty bad advice.  I'm hoping someone can help me adjust the user permissions to "just enough" to allow QB to run, without giving a user full admin rights to our QB server.
0
jcimarronCommented:
Malamamoto--
My "AH"  was being facetious.  It took 20 posts to learn what you wanted.

I have no idea if this will help since I do not run Quick Books.
http://support.quickbooks.intuit.com/support/articles/SLN41414
0
Joe Winograd, Fellow&MVEDeveloperCommented:
So the problem is that QuickBooks is launching Windows Picture and Fax Viewer to open a PDF rather than launching a PDF reader/viewer – right? If so, isn't that a QB issue? I don't have QB and have never used it, but I'm thinking that perhaps it has a config setting that controls what programs to open for certain file types.
0
MalamamotoAuthor Commented:
Yes, except that we temp gave the problem user admin permissions and it started working.  removed admin permissions and it stopped working.  So it doesn't seem to be a QB issue.
0
jcimarronCommented:
Malamamoto--I agree with joewinograd and suggest you close this thread and open a new one with the new details about Quick Books.

People knowledgeable about Quick Books are unlikely to read this thread.
0
MalamamotoAuthor Commented:
will do!
0
marsiliesCommented:
How are you running Quickbooks Pro 2012? You mention a remote IE session. Is Quickbooks installed locally on the PC, or is it installed on a server and people are accessing it remotely?
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Well, you seem to have figured out it's a permissions issue, although I don't know why that would cause QB to open Windows Picture and Fax Viewer rather than the default PDF reader/viewer. But in any case, check the permissions on PDF files for the non-admin users...seems that they're different from the permissions for admin users. If so, change 'em!
0
MalamamotoAuthor Commented:
Solved, recreated the user profile and it worked.  Even without admin permissions.  not sure what happened, but that solved it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MalamamotoAuthor Commented:
it was a user permissions issue that was resolved by deleting the old user and recreating the new one.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Acrobat

From novice to tech pro — start learning today.