Certificate error logging in to Outlook


When logging in to Outlook I get a certificate error of my SBS server name.

I have installed a GoDaddy trusted cert but this is purely for the mail.domain.co.uk name.  I did some research on  this and spoke to GoDaddy and they said a single name cert would be fine.

Who is Participating?
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
Shouldn't need to get a rekey.
As long as you run the wizard and configure it to use your custom name, choosing mail instead of remote, the add trusted SSL wizard should let you choose an existing SSL certificate. No need to create a new request through SBS.

Great article from Sembee on how to configure exchange using single name certificate.
Check this article and verify if your server is configured correctly. It applies to exchange 2010 as well.

If you provide the exact screenshot of the error then it we can tell you where exactly you have to check the settings.
George-Author Commented:

Is this the same for SBS though?  Does SBS not do a lot of this for you?
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

vSolutionsITConnect With a Mentor Commented:
Yes, If you run the wizards correctly while doing sbs setup or implemented the certificate using the sbs wizards then it will configure almost of this automatically for you.
If not then you will have to configure the url's manually for exchange as suggested in the article.
Cliff GaliherCommented:
SBS does almost everything for you. BUT if you didn't use the SBS wizard to generate the certificate request hen you may have generated a certificate differently than what SBS expects. You shouldn't pick and choose which SBS wizards you run. You need to run all of them.

For example, you say your certificate is mail.domain.co.uk, but the default name in the internet address wizard is remote.(domain), not mail. So unless you actively changed the default in THAT wizard, you will get a certificate error.
George-Author Commented:
can i not simply re-run a wizard?

the cert was requested and installed via the wizard.
Cliff GaliherConnect With a Mentor Commented:
I'd rerun the internet address wizard then run the DBS certificate wizard (NOT the exchange certificate wizard!) ...with the new CSR you can request a free rekey from godaddy.
George-Author Commented:
Thanks for all your help.  I have not tested this but believe this will fix the issue but need to close the question.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.