• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3192
  • Last Modified:

10mbps Link Speed - RealTek Family GBE 1GBps - Windows 7 64bit


I have an issue with two Windows 7 workstations with onboard RealTek Family GBE Controller NICS.
They only ever achieve a maximum linkspeed of only 10MBps. The NICS are Gigabit, but the Cisco Catalyst 2950 switch we have is only rated up to 10/100.
I would expect that (as happens at our other sites) that the NICs would run at 100.

All other workstations (4 of them, XP 32bit) and server (Windows SBS 2003) are connected at 100MBps.

I have disabled Large Send Offload for IPv4 & IPv6 on the NIC (before I did this, the linkspeed was a paltry 1Mbps)

I have had the cables swapped out between NIC and data point (despite old previous workstations working fine with same cabling) Cat 5e cable - issue persists.

If I set the link speed manually to 100MBps on the NIC and on the relevant port on the Cisco Catalyst, the link falls over and will only come back up when I set it back to Auto Negotiate on both the NIC and switchport (it will come back up with only the switchport set to auto). It only reconnects at 10Mbps.

I've updated the NICs to the latest drivers provided by Realtek (http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false)
Win7 and WinServer 2008 R2 Driver 7.75 and tried it on the previous driver 7.53 to no avail.

Also ran the below (disabling SMB2 to make them perform better with earlier XP and SBS2003 OS)

Large Send Offload v2 (IPv4) - Disable
Large Send Offload v2 (IPv6) - Disable
netsh interface tcp set global rss=disabled
netsh interface tcp set global autotuninglevel=disabled
netsh int ip set global taskoffload=disabled
sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled
netsh interface tcp show global

We have the same PC's in another site with the same switch, same drivers, same setup and they get 100Mbps without issue.

I've had the PC powered off and unplugged from the mains for 20 minutes to see if it renegotiated at a faster speed upon power up, but it didn't work.

I have been using iperf to track the transfer rates.

Spanning tree is has been enabled and  disabled on all ports on the Catalyst switch and the linkspeed on these two machines is still 10 irrespective of whether spanning tree is on or off...

The Windows 7 PCs (brand new) have consistently been 10 times slower than the other PCs on the network.

At the start of the issue, the SBS2003 server and XP machines (all Broadcom Giagbit NICS) were transferring at 10MBps (despite showing 100mbps linkspeed on Catalyst switch), and the Windows 7 machines ran at 1Mbps.

After disabling large send offload on all NICs on all PC's the SBS2003 and XP machines run closer to 100Mbps, but the Windows 7 PCs run at 10Mbps. Link Speed on the Catalyst for XP workstations and server shows 100Mbps, and 10Mbps for the Windows 7 PCs.

Any ideas please? I'm stumped!

Many thanks :-D
2 Solutions
have you tried setting the Nics and Switches manually to 100 Full rather than auto negotiate, this would be my 1st point of call.
Sam Simon NasserCONSULTANT/DIRECTORCommented:
i would start like this:  what are the cables?

if connected between the PC and switch directly, they should be minimum CAT5e (CAT6 Recommended)

if the PC is connected to wall socket, and thus the wall socket is connected to patch panel, the cable between patch panel and wall socket should be CAT7

i would try this: bring a PC (that connects to 100MB) and connect it instead of the current PC (that link at 10MB) ... does it connect at 10 or 100? this you can determine if it's a PC (driver / software) or connection issue (cabling / sockets)

also, if you have the chance to open the wall socket, are there 4 or 8 cables connected?
ronnie_urbanitAuthor Commented:
bart1975 - I have had the NICs and the relevant switchports  set manually to 100Mbps/Full - in this instance the link doesn't come back up at all. The link only comes back up when I set the switchport back to Auto/Auto. if the NIC stays at 100Mbps Manual, the link comes back up but at 10Mbps - If i set the NIC back to Auto as well, it stays at 10Mbps.

Samnasser - I'm offsite so cannot confirm what the cable bewteen wall socket and patch panel is (not likely to be Cat7 at a guess)

I have had them plug in their previous PC (XP, 32bit, Broadcom Gigabit NIC) into where the new PC is, straight in with the same cables and they get 100Mbps right off the bat.

It's only the two Windows 7 64 bit PCs (HP with Realtek NICs) that exhibit these slow link speeds

Cheers :-D
7 new features that'll make your work life better

It’s our mission to create a product that solves the huge challenges you face at work every day. In case you missed it, here are 7 delightful things we've added recently to monday to make it even more awesome.

Verify the cabling is good, not just the patch cables, recently had similar issue where the resolution was to re-terminate the patch panel's female connection. Note that the very same system on the run ran at gigabit speed for several months before connectivity became intermittent and the connection would only remain up when switch and nic set to 10mb. Also verify your runs cabling.  568A type - 1. wht/grn 2. grn 3. wht/org 4. blu 5. wht/blu 6. org 7 wht/brn 8. brn  568B 1. wht/org 2. org 3.wht/grn 4. Blu 5. wht/blu 6. grn 7 wht/brn 8.brn  Also seen where cable run in wall wasn't terminated to correct pairs and caused connection speed issue.
In your first post you said you  were getting 10MBps and you expected to get 100Mbps.  

So Just to make sure as you understand, you seem to be mixing "B" and "b".

10 MBps = 10 mega BYTES per second

100 Mbps = 100 mega bits per second

Roughly 100 Mbps = 10 MBps.
ronnie_urbanitAuthor Commented:
Hello all, apologies for mixing the lower case/upper case B - to simplify: when I get the status of the network connection I'm getting link speed of 10, not 100.

After further checking it would appear the data points themselves are in a pretty bad way, with the previous owners attempting some DIY cable runs.

Contrary to my earlier post, I double checked another PC which runs at link speed of 100 elsewhere in the depot in the datapoint and it runs at a link speed of 10.

I'm not onsite but I suspect that the data points need some repair/replacement and it may even be that two data points are running off one cable, with the pairs being split between them. It is only these two points in an isolated office that are running at a linkspeed of 10, all others are 100.

Thanks for all your help!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

7 new features that'll make your work life better

It’s our mission to create a product that solves the huge challenges you face at work every day. In case you missed it, here are 7 delightful things we've added recently to monday to make it even more awesome.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now