Exchange 2010 sending slowly

Our company sends out email blasts weekly to about 20,000 email addresses. On our old Exchange 2003 server this would take about 1.5 hours to send out. On our new Exchange 2010 server it takes about 19 hours.

I've set up a connector that allows the mass emailing software IP to rely off of the mail server anonymously. I've configured the throttling policy as follows

AnonymousMaxConcurrency                     : 20
AnonymousPercentTimeInAD                     : 5
AnonymousPercentTimeInCAS                   : 205
AnonymousPercentTimeInMailboxRPC      : 200

Here is a screenshot of the the full Get-ThrottlyingPolicy
Get-ThrottlingPolicy ScreenShot
It takes about 3.5 seconds per email compared to the old server that took about .25 seconds per email. Any ideas on how to get our speeds up? Do I have the throttling policy all messed up or is there another setting I need to play with?
LVL 2
David11011Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Set everything to blank and then check.
0
David11011Author Commented:
I only need to change the settings for the anonymous right? there's no default settings somewhere I need to make changes too?
0
AmitIT ArchitectCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David11011Author Commented:
Thanks! that did it. I created a connector just for the email blasts and set the MaxAcknowledgementDelay to 0 on that connector.

Also I've discovered that I needed to turn of Tarpiting.

set-ReceiveConnector "connector-name" –TarpitInterval 0

Thanks for you help.
0
AmitIT ArchitectCommented:
Great it worked for you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.