Send as - problem

I got an Exchange 2010 and I have provided send as permission to a user named Ben but  he gets  "you don't have the permission to send the message on behalf of the specified user" when he sends as the marketing mailbox.

Tried assigning permissions from both the EMC and AD ( security tab ) but no joy. I made sure that inheritance is enable on the marketing object.

( see attached )

Any ideas ?
Inheritance.JPG
R2_D2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AdrienneSperberTech Support CoordinatorCommented:
try adding that user to send on Behalf of, also restart IIS
0
Will SzymkowskiSenior Solution ArchitectCommented:
Does this user have "Send on Behalf of" as well? If this is true remove it. Use one or the other. Also do you have delays in your AD Replication? Does the user that has permission to send as using Outlook cached mode? If so this also stores permissions and only updates every 24 hours.

Remove cached mode and try again. Also, create a new Outlook profile and test again in case the profile is corrupt.

You can also restart the Info store service which will speed up this process. Might not be recommened during produciton hours but this is also an option.

One other thing... If you are using Exchange 2010 you should be able to "Send As" in OWA as well. This will eliminate any possible issues with Outlook.

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simon Butler (Sembee)ConsultantCommented:
"Does the user that has permission to send as using Outlook cached mode? If so this also stores permissions and only updates every 24 hours"

That is wrong.
Outlook doesn't store any permissions. The only permission cache to worry about is the one in Exchange, which flushes around every two hours.

Simon.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

R--RCommented:
Restart exchange services and check.
0
R2_D2Author Commented:
Dear All,

1.- The user is set to "send as" only.  Although if i try the "send on behalf" it works.
2.- "send as" from OWA works but doesnt work in outlook.
3.- Cache mode is disabled
4.- I got a DAG and restarted all the servers but I didn't dismount the DB, i just moved from one server to the other while restarting the servers.

I think deleting the marketing mailbox and create it again is to aggressive, I will do it as a last resort.

can you guys help ?
do you need more info ?
0
R2_D2Author Commented:
Guys you are very quite.

Has anyone got more ideas ?
0
Simon Butler (Sembee)ConsultantCommented:
You are aware that people aren't paid to answer questions? Most people have day jobs, so chasing after a day isn't really polite. When I got up this morning I had 145 questions wanting my attention.

If it works from OWA for Send As, then it is unlikely to be a permission issue. You need to try it from another machine.

Simon.
0
R2_D2Author Commented:
I have tried on the user's machine and on mines, the outcome is the same.

I will try a DB dismount this weekend, meanwhile any other ideas are welcome.
0
Will SzymkowskiSenior Solution ArchitectCommented:
If you are using OWA and it is working then it is clearly a client issue and permissions are set accordingly. From my experience when using cached mode in Outlook, permissions changes do not update instantly. Try using Outlook in "online mode" disabling cached mode and see if this works for you.

@Simon - thanks for point that out above Simon, learn something everyday. I was just stating the 24hrs to update as that is normally what i tell my users if they are using cached mode.

Will.
0
R2_D2Author Commented:
Sorry for the delay in getting back to you
Re-mounting the DB fixed the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.