Outlook anywhere

Please can anyone help  I cannot connect to outlook anywhere .
Remote Desktop works
Outlook web access works
VPN works
Outlook will connect if the VPN is used.
but even with all the correct connection settings outlook does not connect .
Who is Participating?
Cliff GaliherConnect With a Mentor Commented:
Self issued certificates are a right pain and always have been. With SBS 2008 onwards, you *must* deploy the trusted root. Trusting the leaf alone is not good enough. If you don't deploy the trusted root to the machines using Outlook Anywhere (which is particularly tough to do for home users using their own personal machines) then you will get this error. Always. Full stop.

Deploying the self-issued trusted root:


Or...buy a certificate. It would have paid for itself already just in the time you've spent writing this question, reading replies, and running the one test you've been asked to run.
Cliff GaliherCommented:
Well, you haven't given us much to go on. No error messages, no details of your network topology.

So I'll start with a simple suggestion. Use Microsoft's remote connectivity analyzer tool. It has a test specifically for Outlook Anywhere. That will at least help us know what questions to ask...

samcoryAuthor Commented:
everything passed up till here: (I had no problem with SBS2008 using the self issued certificate!)

  Attempting to resolve the host name remote.mydomain.com in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 99.106.xx.xx Elapsed Time: 33 ms.  
 Testing TCP port 443 on host remote.mydomian.com to ensure it's listening and open.
  The port was opened successfully.
   Additional Details
  Elapsed Time: 182 ms.  
 Testing the SSL certificate to make sure it's valid.
  The SSL certificate failed one or more certificate validation checks.
   Additional Details
  Elapsed Time: 7744 ms.  
   Test Steps
   The Microsoft Connectivity Analyzer is attempting to obtain the SSL certificate from remote server remote.mydomian.com on port 443.
  The Microsoft Connectivity Analyzer successfully obtained the remote SSL certificate.
   Additional Details
  Remote Certificate Subject: CN=remote.mydomian.com, Issuer: CN=mylocaldomian-MY-SERVER-CA. Elapsed Time: 7701 ms.  
 Validating the certificate name.
  The certificate name was validated successfully.
   Additional Details
  Host name remote.mydomian.com was found in the Certificate Subject Common name. Elapsed Time: 0 ms.  
 Certificate trust is being validated.
  Certificate trust validation failed.
   Test Steps
   The Microsoft Connectivity Analyzer is attempting to build certificate chains for certificate CN=remote.mydomian.com.
  A certificate chain couldn't be constructed for the certificate.
   Additional Details
  The certificate chain couldn't be built. You may be missing required intermediate certificates.
Elapsed Time: 21 ms.
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

samcoryAuthor Commented:
I did as requested and loaded the SBSCERTIFICATE.CER
then put the details into my computer

and I still get a message:
"the action cannot be completed. The connection to MS Exchange is unavailable. Outlook must be on line or connected to complete this action."

(Taking note that the connection to Outlook works with the VPN connected)

The settings of the email in the connections part were:
connect using  my local network - TICKED
Connection to MS Exchange using HTTP - TICKED

Exchange proxy settings are:
https:// remote.mydomain.com
connect using ssl -TICKED
(also tried  puting a tick in  "Only connect to proxy servers that have principal name etc" with the line "msstd:remote.mydomain.com")

samcoryAuthor Commented:
Got it work. Was putting the certificate in wrong place.
Thank you for your prompt help
samcoryAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for samcory's comment #a39558161

for the following reason:

Thanks for your prompt help in guiding me in the right directin
Cliff GaliherCommented:
Did you accept only your own comment on purpose?
samcoryAuthor Commented:
No I meant to thank CQALIHER  for his help and award him the full points for his excellent and quick help
Please fix.
sorry for the trouble
Cliff GaliherCommented:
Per comment 39561516
samcoryAuthor Commented:
Comment 39561516 should read as a thank you to cgaliher

sorry for typo
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.