• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4146
  • Last Modified:

Two computers with the same name on domain

Two computers on our domain, both intermittently on the network, were having issues with 'lost trust relationship.' I discovered that they both had the same computer name on our domain. When I confirmed this, I removed Comp #1 from the domain, then rejoined. Next I renamed Comp #2, then unjoined and rejoined the domain. Problem: Comp #2 now appears in AD, but with the properties of Comp #1; and Comp #1 can no longer be found as a computer object in AD; it's as though they merged into one under the new name after it joined the domain.

How can this be resolved so they are both computer objects in AD with their individual names and properties?
2 Solutions
Now they have 2 different names...1 item done.

Move both to a workgroup.

Check AD to make sure the computer names are gone...if not, delete them to make sure AD will not get confused again.

Re-add both computers to the domain.

(I am assuming the computers were NOT created from the same base image or sysprepped properly...computers with the same SID will confuse AD as well)
Will SzymkowskiSenior Solution ArchitectCommented:
When adding computers to the domain you should pre-stang them. Meaning create the computer objects first then adding the computers using the accounts created. This will resolve your issue.

sjcallenAuthor Commented:
Thank you - done - success!
SandeshdubeySenior Server EngineerCommented:
It seems that machines are created from and image that is NOT prepared with sysprep.If this is the case refer below links.Also ensure that only the domain DNS is configured on client/member server and None else like public IP address.

What Is Sysprep?  http://technet.microsoft.com/en-us/library/dd799240%28v=ws.10%29.aspx

How Sysprep Works  http://technet.microsoft.com/en-us/library/dd744512%28v=ws.10%29.aspx

How to Sysprep in Windows Server 2008 R2 and Windows 7  http://briandesmond.com/blog/how-to-build-a-sysprep-answer-file-for-imagin

It could be also that multiple DC are present and object are still not replicate force the replication and check.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now